Jump to content

B4 Bug Thread


lucid
 Share

Recommended Posts

- Custom Background-Color:

if I had a color selected, maybe green, and than pressing again on custom background color, but pressing "CANCEL", the background has to be like before, maybe green, but it turns into black

a feauture would be also when the custom-background-color-button acts like the white-background, gray-background and black-background, and the color-selector only appears if I had pressed the custom-color-selector, and when I press it after white, gray, or black, that my color, I chosed before will come.

- No sprites seen. When I zoom out, so that there is no scroll-bar shown on the right or down, only the sprite in the last layer is shown.

In my case my last layer is blue square 1000 px x 1000 px, also the sprites with a width of 1000 px are shown, the have a height of 106 px. But sprites smaller 1000 px in width or height are not seen

- the preview window on the right in the File Palette shows images in full size without scaling, so when I have a 1000 px x 1000 px image, the preview window is over the edges of my monitor's view, so I don't see the [OK] or [CANCEL] button

post-10433-14159834111612_thumb.png

post-10433-14159834113881_thumb.png

Link to comment
Share on other sites

two things I noticed...

1) The object properties section (like x, y, for example) does not update based on selection when moving the animation timeline (maybe to keep it simple, should update based on current selection when you let go of the slider?)

2) on mac, please make the backspace key work like delete, as is standard practice for macs.

thank you,

-Nick

Link to comment
Share on other sites

a few things I noticed when playing around (in Windows 8):

- I created a quick test character and rigged him with bones to test dynamic re-rigging. So I chose to have him take off his hat (which consists of two separate parts -one in front and one behind his head- that are perfectly aligned but have a different Z and different image-dimensions). The animation itself is 803 frames long, but the timeline is 1000 frames. The re-rigging takes place on the second key. When I go to any frame after the last key, the hat get distorted as shown in the image below. I think I only noticed it after I loaded the project again.

SpriterTest_zps577e5cd7.png

- changing the Z-order of an element using Ctrl-Up, Down, Left, or Right doesn't update (neither in the Z-order panel, nor in the central view) until I click the central view (clicking any of the other panels doesn't initiate the update).

- setting a transition to 'instant' rather than 'linear' doesn't seem to have any effect.

- possibly not a bug but a design-decision, but when I zoom in using the mouse-wheel, then change the zoom using the keyboard, and then use the mouse-wheel again to zoom, the zoom starts from to the last zoom set with the mouse-wheel rather than the current zoom-factor (set through the keyboard).

Link to comment
Share on other sites

Hi Misj',

I'm not sure how the error was created (maybe a bug, we'll keep looking into it) but at least the solution is simple. Please watch this video:

http://youtu.be/nT2k3nXpuCU

Somehow a single key was created just for the hat bone which was hidden under the main key frame for everything...this single bone key was the key that was causing the issue.

The solution (as seen in the video.)

1) Click and drag the last main keyframe to move it a small amount to the left.

2) Reveal the timelines for all the other objects and see the "stray" keyframe for the hat bone.

3) Delete that stray hat bone keyframe.

4) Click and drag the last main key frame to bring it back where you wanted it.

fixed. :)

Link to comment
Share on other sites

Hi! I have just bought the pro version and so far Spriter is an awesome software :D .

However, I got a bug relating to bone I guess. When I use the bone, attach sprite to it, set an animation, save, quit, then when I open it again the bone position is all screwed. After that I decided to make a new one and every thing is normal.

I would like to give you the scml so you can check it, but unfortunately the sprite has been edited so it might be not exact anymore.

Here, I attached the scml file without the sprites.

And for suggestion, I hope you can give border in Timeline area, the keyframes (dot) in the border (first and last frame) are hard to be picked.

And... scml plugin in C2 seems buggy in "on animation end" part.

Thank you very much.

ps: if you want to see my work using spriter, check this out:

move using arrow, and in the island border push up to cast rod. It is mainly broken, but you get the idea. Created using C2.

https://dl.dropboxusercontent.com/u/702 ... index.html

Link to comment
Share on other sites

I was creating an example combining bones and scaling of the images AND bones in Spriter B4, to test with my implementation of the SCML format.

1. Created a project using a folder that had one image and saved it there.

2. Dragged the image in Spriter into the workspace to create an object and set some rotation and scaling and modified the pivot.

3. Added a bone and attached the image to it.

4. Moved to another time and rotated the bone, which created a new key frame.

Then I realized that I would like to add another image as a reference to see that everything is calculated correctly.

5. Moved back to the first key frame and dragged the SAME image from the File Palette and positioned it.

6. When I moved past the second key frame the image disappeared, so I dragged it in again on that key frame.

7. Saved.

Ended up with:

As you can see there's a slash in the file name. Spriter can load the project but in the current state my implementation failed to load the image as there was no dot before the slash. So I am wondering why a slash is added at all.

Link to comment
Share on other sites

Baterism. That issue is fixed in the next version of the plugin. Meant to release it before i left this weekend, but i ended up tweaking the scml docs until the last minute and never got around to it. Will release it upon my return wednesday.

Magwill, thats a bug. I will take a look when i return

Link to comment
Share on other sites

Hi

I'm animating a character with a series of different head sprites. Whenever I would replace one sprite (via the right click feature), it not only replaced the sprite on that key frame, but also in the previous key frame. Once I go back to the previous keyframe and change it back, it's okay, but I had to do this after each replacement. I don't remember this happening before, so I'm guessing it's a bug, but is there something I might be doing that's causing this?

Thanks!

Link to comment
Share on other sites

I am trying to use images from different folders, but have been having problems.

If I edit the .scml file in Notepad to read:




...then the file loads fine and loads all images.

However when I then save this and look at the saved file in Notepad, it has been changed to:



which then loads but all the images are missing until I manually edit the paths again.

What are the plans with regards to multiple image folders, and using scml files inside each other (dragging a full character into another animation for example)

Link to comment
Share on other sites

Bug : crash when deleting two hierarchies at the same time on a whole animation

Procedure :

1- Select two bones in separate parts of the hierarchy

2- Press Z

3- Press "Shift" + "Suppr"

Screenshot :

1374595579-screen-bug.png

Don't forget, Valerien, on English based keyboards, its called the delete key.

Thanks very much for the concise bug report. I'll make sure Edgar gets this bug report forist thing in his morning. ;)

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Hi now that i have updated my Spriter from b3 pro to b4 pro now no matter what i do every time i try to save the program crashes! i can only delete existing animations and save without breaking the porgram and getting the "program have stopped working" message, i cant stress how frsutrating this is, especially cause i dont have the older version anymore so i could go back to it while you guys fix whatever causes this :S

I know i`m supposed to provide more info but its not a specific bug, i get this every time, i`m using the typical win7 64bit and had no real problem so far, but this is very very anoying, is there any way to get b3 version again, because now i cant do anything at all.

Link to comment
Share on other sites

Forgot to mention the error i`m getting is:

Problem Event Name: APPCRASH

Application Name: Spriter.exe

Application Version: 0.0.0.0

Application Timestamp: 51ddee05

Fault Module Name: QtGui4.dll

Fault Module Version: 4.8.1.0

Fault Module Timestamp: 4fa9a34f

Exception Code: c0000005

Exception Offset: 0046ff50

OS Version: 6.1.7601.2.1.0.768.3

Locale ID: 2057

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I whould really appritiate the help, or just the old version of spriter cause i`m on a tight timeline for my current project.

Link to comment
Share on other sites

hi grayborders, I'm emailing you the link to B3, because you're in a rush, but if you could try two things first, it may solve your problem, and allow you to keep using b4. First is disable OpenGL in the view menu. If that doesn't work, uninstall Spriter and make sure all dll's are deleted from the install directory (or that the directory is completely erased, before reinstalling). If neither of those works, you can use the link I email you to download B3 as a last resort. Also, there should be a new version released soon.

Link to comment
Share on other sites

Thank you very much!!!!

I tried both fixes but unfortunately neither worked, the old version is working fine!

I didnt plan on coming to this forum just yet, wanted to do that when i finished my first project.

I cannot tell you how amazed and satisfied i am with Spriter so far, its an amazing tool tailor made for the animation style i always wanted, and the way the ui is made up, makes it eren better, fast to learn or adapt to from other programs, and its an all around simple and amazingly usefull tool to shorten what is normally a pain in the butt process, if you are a bit capable of thinking ahead Spriter will give you a speedup of 400% :D

There i praised you guys enough for the day :D I`m very very grateful for your quick response as well as creating spriter! You guys gave me the tool to hopefully make my dream come true :)

Link to comment
Share on other sites

btw, anyone who's getting the issue of a mysterious "object_000" appearing in their project. I'm trying everything to reproduce the issue, but I can't get it to happen. It's obviously not an isolated thing, since I've seen it reported at least 2 or 3 times already, so if anyone figures out a way to make it happen on command, I'd be very grateful

Link to comment
Share on other sites

Apologies if this was posted elsewhere, I poked around a bit but didn't see it.

Seems like IK lock/anchor doesn't update to the current keyframe when changing time. The preview looks okay but as soon as I drag a bone, the locked ones revert to the pose the bones were initially locked at. It works if I unlock and re-lock the bones, but it's a slowdown in my workflow.

Link to comment
Share on other sites

Clicking "current time" to enter the time manually doesn't focus the text field - 90% of the time I end up hitting a shortcut key.

Along those lines, it seems strange to me that pressing enter after entering a new timeline length doesn't "Apply Length" (though that text field does get focus properly)

Also, skipping between keyframes moves the timeline's vertical scroll back to the top every time. It's okay when I've got the timeline window undocked to fill my second monitor but in one window it's annoying to have to scroll back down to the layer I'm working on every time I skip a frame.

Link to comment
Share on other sites

Also noticed that sprites replaced via character map don't pick up the custom pivot of the original sprite, resulting in a noticeable offset.

This is no bug, this is by design. If pivot points are set carefully for all images (originals and replacements) there will be no offset. If the new image picked up the default pivot-point of the original image but was a diferent sized image, the offset could be catastrophic. If your original and replacement images are identical, just set both default pivot points identically.

We do plan, however to make it very easy to copy and paste default pivot points from image to image, or from same sized images with same name across folders in a future release though.

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...