Jump to content

B4 Bug Thread


Recommended Posts

Spriter B4 crashes when saving a file on Windows 7

I have a file that Spriter correctly loads. But it always crashes when I try to save it, even if I just open and immediately try to save. Spriter freezes, closes, and the new file is created, but is empty (0 bytes)

I have plenty of disk space and disk write access for these files and folders. I tried saving on other folders and it's the same.

The strange thing is that it was working somedays ago, perfectly. I've changed nothing in this file or folders (I even reverted the files to a week later version, using configuration control software). It simply stopped saving.

Maybe it's something related to the local configuration? Can I delete it to fully uninstall spriter and get a fresh new install? I couldn't find where the local config is saved on Windows.

This is a critical bug for me, because I can't create or edit anything! Is there a download link for to the previous release (b3), so I can try it until this is fixed?

Link to comment
Share on other sites

I want to chime in Alex isn't the only one who is having this problem. I thought I had crashing on certain edits, but I was wrong. Saving period will cause Spriter to crash and 0byte the file.

However, hunting through my animations. I found some "Object[#whatever number]" in the sprite object to the left side. When I click on the object I get a black screen. When I delete the object Spriter crashes.

I think this might for me be caused by removing images from the palette directories before removing them from the animation. As a thought maybe some kind of validator to check to see if all images are there. If not remove the Object?

This might help it may not, but like alex. I'm in the boat that until a fix comes out there is nothing I can do. I also sent the file a little while ago, but wanted to add some information and commiserate with a fellow also stuck :)

Link to comment
Share on other sites

I think I'm having a similar issue to jayderyu. I made an animation a week or two ago (the same one having issues with replacing sprites that I posted about above). It seemed to be saving just fine, but when I tried to open it today, only one of the sprites was showing up and animating, though all of the keyframes appeared to still be there. The file palette still shows all of the correct pngs, but in the z-order and hierarchy, they are all labelled as object_###, the bones are gone, and when a blank object is clicked the screen goes black or half black, half gray. I tried replacing the blank objects with pngs from the file palette, but none of them have retained their correct positions. They just stack in a pile on the stage and do not animate (though they do get selected instead of showing a black screen). The z-order seems to change still though.


https://dl.dropboxusercontent.com/u/899 ... nshot1.png

https://dl.dropboxusercontent.com/u/899 ... nshot2.png

Link to comment
Share on other sites

I am trying to use images from different folders, but have been having problems.

If I edit the .scml file in Notepad to read:

...then the file loads fine and loads all images.

However when I then save this and look at the saved file in Notepad, it has been changed to:

which then loads but all the images are missing until I manually edit the paths again.

Is this a bug or by design?

Link to comment
Share on other sites

Hellou there, reporting in that both B4 and B3 version of spriter gets stuck for me. I can't add any parts I have in my files (they are greyed out I think) neither can I click most of the buttons at all. Play animation does work but pretty much everything else is just stuck.

(ah okay I just found out that you have to restart computer to make it work)

Link to comment
Share on other sites

I have a question to those with the Object_xxx or crashing saves.

What version did you start your project?

I started mine in b2, and I'm thinking that the problem might be a legacy problem(just a thought). I'm theorizing that the crash is some kind of b2/b3 safety mechanism that's been removed due to b4 being improved and more stable. So knowing when we started our crashing projects might help solve the problem.

Link to comment
Share on other sites

I haven't found the bug :( However for those that B4 is crashing on I have some information if you need to get back to animation work. I started experimenting with the SCML file and the unknown and unwanted objects. After playing some I managed to get my SCML to save again without crashing. Here I give some instructions on what to do.

1. Create a backup. Just start keeping back ups until everything is stable :D

2. Open up the SCML backup in a text editor(you want as little markup tags as much as possible. Try notepad or notepad+)

3. Start a search for "object_0". Often the object will look like below. DELETE the entire thing. From open to close.


4. Repeat the process until all "object_0xx" are gone.

5. Test out by using "save new version". If you get a crash you won't break your work file.

I found that doing so may cause up deleting a bone :(. There might be a reckogniazble difference in these "object_xxx", but I didn't notice it. I know have a savable file for b4. Though I need to fix up some of the images :(

what creates these object_xxx, I don't know yet :(, but i think it's a b2 thing.


I found two problems with doing this.

1. the object_xxx will leave a blank space in the order list on the left

2. I am also now missing a bone :D. Which seems to have messed up the graphical object :D


hmmmmm. found a problem with this. repainting is acting strangely and sometimes crashes :(

Link to comment
Share on other sites

I thought I had answered you elsewhere. There are currently no plans to allow you to include files from outside your project folder. This issue will be alleviated as Spriter is expanded to let you combine projects, and more easily import or change source image files.

Link to comment
Share on other sites

hey jayderyu,

it sounds like the issue you're having is if you just deleted all the offending object, all of the object_refs, and bone_refs will have a gap in their 'timeline' ids. So you have to make sure that you renumbered the timelines after the missing one

if you remove object_000, you have to renumber the timelines:

and make sure all the refs to those later timeline id's points to the correct value.

if you're still having trouble with the file, please send it my way and I can finish repairing it.

Also, is there anyone else who disagrees this was probably caused before version b4? has anyone had this ghost object nonsense with the latest version. I've been working on other fixes and features as well, but every time I come back to this bug and do more testing, I still can't reproduce it

Link to comment
Share on other sites

@ Buttermonster,

Wow, We've been trying to figure out how to reproduce this bug for ages! Can you please ecplain in full detail (step by step) how to cause this broblem with version b4 when starting from scratch (a new project)?


Mike at BrashMonkey

Just an scenario from a project I was working on yesterday:

I started a project from scratch and made an animation. Saved the project. No empty object bug when I opened the file again.

Using this project, I started a new animation by cloning the original one, then made modifications on the cloned animation. Saved. When I opened the file the original animation had the empty object bug, but not the cloned animation that was modified.

I started a new project and made an animation, saved. Created a new animation by using the "new animation" button, then copied objects from the previous animation into the new one. Saved. Opened the file again and no empty object bug was present.

This was done on the latest version. Since I stopped using the clone button I haven't had any problems or crashes so far. It is a bit of a pain to copy objects specially with more complex characters, but seems to be an ok workaround right now.

Link to comment
Share on other sites

Hi again Buttermonster,

Edgar and I have both tried to reproduce the bug with the steps you just described and did not manage to reproduce the corrupted file issue.

1) I started a new project, pointing Spriter to a folder which already had a subfolder with PNG images in it.

2) I created an initial animation, with three images, three bones, and many keyframes.

3) I saved.

4) I reloaded, so far all is fine.

5) I cloned the first animation to create a second animation.

6) I edited this new animation so its diferent from the first.

7) I saved.

8) I reloaded. There was no missing images, no problems at all.

Can you think of something you we're doing that we are not?

Are you naming the animations? if so, at what point in the process? Are you moving images from folder to folder? Is there something else you are doing that you've not yet described?

Any chance you could use a program like CamStudio (its free) to record your screen and recreate this bug for us so we can see exactly what is happening every step of the way?

What OS are you running spriter on BTW?


Mike at BrashMonkey

Link to comment
Share on other sites

Came here to report the object_000 problem (actually put in object_000, object_001, object_002, and object_003), and saw your discussion here about it above.

I'm using the latest version of the software.

I want to second the question: Will the hotfix fix existing projects that have encountered this bug? If not, what's a fix or workaround?

Link to comment
Share on other sites

Hi Everyone,

Edgar hopes to get the hotfix out within the next 2 days.

The hotfix will make the file no longer corrupt, BUT unfortunately the data that is lost (those objects) is truely lost and we have no way to retrieve.

The corruption is caused when a user deletes the last frame in any animation which contains one or more objects which are also in other animations....basically, it will remove those objects from ALL animations.

So, the most comon cause of this data corruption is a workflow that includes cloning animations and then deleting every frame of a specific object from the cloned animation...as this is guaranteed to delete objects that are shared in other animations.

Of course we'll post news of the hotfix as soon as it's ready on Facebook, Kickstarter, these forums, twitter etc.

thanks everyone for the testing and patience as we iron out this issue.


Mike at BrashMonkey

Link to comment
Share on other sites

  • 2 weeks later...

Hi Cloak and Dagger, the fix will be out by this Sunday. It will be version b5, which will be mostly just bugfixes. The corruption bug is already fixed in my working build. Unfortunately, I just upgraded the UI framework to the latest version, which created a few minor ui glitches I'm working through, and then we found out how to reproduce the corruption bug just after the switch, and associated code changes. Also, there are several pro features that are pretty far along, but we will delay them until the next build to get this out sooner. So I need to roll back the partial implementations. I apologize for the delay.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...