Jump to content

Spriter R6 Bug Thread


lucid
 Share

Recommended Posts

  • lucid pinned this topic

Same bug persists - child bones are getting keys of parent bones, how to do it ?

create bone 1 , create its child bone (bone 2) , now go to timeline lets say 500 , move bone 1 and thats it .Now bone 2 has key as well but it wasnt moved at all, only bone 1 was moved.

because of this bug i have to remove A LOT of keyframes to get smooth S curve between two keys.

I dont know it its the nature of how spriter works or its a feature but i would like ability to disable it at least temporary.

This bug causes big problem when i have a lot of work done and i want to change a bit rotation of torso bone on time 300, if i move it then all limbs parented to torso will be keyframed on time 300 as well , this is not what i want cause its messing up smooth s curve motion between 2 keys when additional 3rd key is inserted on all limbs because i moved torso bone, i want only torso to get keyframe , not its limbs.

Link to comment
Share on other sites

I'm having an issue with performing a batch export after the update, spriter crashes after I select the folder destination. I thought it might have been a corrupted file so i switched to my backup save but it crashes on that too. I then created a while new file and tried but with the same result. On a personal note this is a really terrible time for this to happen as I have a deadline for a game and the fact that I can't batch export sprite sheets is extremely concerning.

I've attached what settings I have just in case that might help

Capture1.PNG

Capture2.PNG

Link to comment
Share on other sites

Hi Fangoram, Can you verify if the export does not crash with the previous build of Spriter (r5)? You can download previous builds from here:

 

Thanks, Mike at BrashMonkey

 

3 hours ago, Fangoram said:

I'm having an issue with performing a batch export after the update, spriter crashes after I select the folder destination. I thought it might have been a corrupted file so i switched to my backup save but it crashes on that too. I then created a while new file and tried but with the same result. On a personal note this is a really terrible time for this to happen as I have a deadline for a game and the fact that I can't batch export sprite sheets is extremely concerning.

I've attached what settings I have just in case that might help

Capture1.PNG

Capture2.PNG

 

 

Link to comment
Share on other sites

4 hours ago, germanmolto said:

Same here... Also, when copying and pasting keyframes sometimes it pastes the entre keyframes from that máster keyframes instead of the ones I copied.

Hi germanmolto,

 

When you copy, I assume you're cusing the keys? (control+shift+C) and then control+V to paste?

Can you confirm this and also let me know which OS you're running Spriter on?

Thanks,

Mike at BrashMonkey

Link to comment
Share on other sites

41 minutes ago, BrashAdmin said:

Hi Fangoram, Can you verify if the export does not crash with the previous build of Spriter (r5)? You can download previous builds from here:

 

Thanks, Mike at BrashMonkey

 

 

Batch Export is a property of the pro version, which i have on steam, I'm unable to batch export with the standalone version. And I don't know my serial code anymore. I will add that I was working all day with spriter up until the update mid-day and then i couldn't batch export

Link to comment
Share on other sites

53 minutes ago, BrashAdmin said:

Hi germanmolto,

 

When you copy, I assume you're cusing the keys? (control+shift+C) and then control+V to paste?

Can you confirm this and also let me know which OS you're running Spriter on?

Thanks,

Mike at BrashMonkey

Hey Mike. I'll give it a try at the office on monday and tell you if that was the issue.

Link to comment
Share on other sites

I am having this issue too. I am no longer able to batch export animations. I have also tried on different operating systems. OSX Mavericks and Windows 10. No matter what folder I try I cannot batch export. I have the steam version and before this update I batch exported multiple animations. This is a serious problem because I am making a game for a school project and I have already used it to make half of my in-game characters. Where can i download a previous version? There is no way I can individually export each of these animations.

Link to comment
Share on other sites

The bug I am getting causes Spriter to shut down completely and, while at first I thought it was happening every time I tried to import one project into another, I now realize it is happening only with specific spriter files.  I tried to debug it in Visual studio only so that I could potentially give you guys more information in an error shot, so those are attached.  I can also provide the scml file for which it bugs out if you'd like?

Thanks,

bugSnap1.PNG

bugSnap2.PNG

Link to comment
Share on other sites

I've confirmed it myself as well and reported to Edgar. Batch export is broken and crashes in R6 but works fine in r5. if you need to batch export, please reinstall r5 for now:https://brashmonkey.com/forum/index.php?/topic/3146-download-past-spriter-builds-here/

52 minutes ago, eizak said:

I am having this issue too. I am no longer able to batch export animations. I have also tried on different operating systems. OSX Mavericks and Windows 10. No matter what folder I try I cannot batch export. I have the steam version and before this update I batch exported multiple animations. This is a serious problem because I am making a game for a school project and I have already used it to make half of my in-game characters. Where can i download a previous version? There is no way I can individually export each of these animations.

 

Link to comment
Share on other sites

5 hours ago, BrashAdmin said:

I've confirmed it myself as well and reported to Edgar. Batch export is broken and crashes in R6 but works fine in r5. if you need to batch export, please reinstall r5 for now:https://brashmonkey.com/forum/index.php?/topic/3146-download-past-spriter-builds-here/

 

The old versions that you can download dont support batch export because you have to have spriter pro to batch export. I have Spriter Pro on steam so this doesnt work for me. What should I do?

Link to comment
Share on other sites

4 hours ago, eizak said:

The old versions that you can download dont support batch export because you have to have spriter pro to batch export. I have Spriter Pro on steam so this doesnt work for me. What should I do?

Same issue here... Can't export the spritesheets and is driving me crazy... It freezes And I don't know how to downgrade my steam versión of spriter.

 

Link to comment
Share on other sites

1 hour ago, lucid said:

@mattcusprime please do send me the files at lucid@brashmonkey.com .  Making it crash while debugging here is the quickest way to find the cause.

Absolutely, will do.  And while I am not concerned about this, but in order to reproduce it I had to zip the folder as a whole, would you mind after debugging just deleting all the project files I send you?  I was only able to do it specifically with this folder structure so I had to zip it the way it exists today for it to work...

Link to comment
Share on other sites

Something went wrong with version 6.1 now i suddenly have disk missing error mentioned by someone else some time ago on forums, its with character thats using maps , if it helps, i dont know, with other characters it works fine and opens project normally, but that one with maps doesnt work because of this error.

It doesnt happen with version 6.only with 6.1

Link to comment
Share on other sites

5 hours ago, mattcusprime said:

would you mind after debugging just deleting all the project files I send you?

I can and will definitely delete them right after debugging.

49 minutes ago, bwwd said:

if it helps, i dont know, with other characters it works fine and opens project normally, but that one with maps doesnt work because of this error.

It doesnt happen with version 6.only with 6.1

Any chance you can send me that non-working project.  As above I will delete as soon as I'm done.  I'm not having any issue loading files with character maps.  I tried a few.  
And you're saying you tried again with version and 6 and it worked fine?  Or just that the problem didn't start until you tried 6.1?

Link to comment
Share on other sites

I have another issue with the batch export where most but not all animations are successfully exported to sprite sheets, I think it might have to do with the high number of keyframes on these three but other animations with the same number of keyframes exported without issue. This isn't a huge issue since I exported each keyframe as an individual image instead, but I would like for the spritesheet exporter to return to its former patch glory.

Link to comment
Share on other sites

48 minutes ago, Fangoram said:

I have another issue with the batch export where most but not all animations are successfully exported to sprite sheets, I think it might have to do with the high number of keyframes on these three but other animations with the same number of keyframes exported without issue. This isn't a huge issue since I exported each keyframe as an individual image instead, but I would like for the spritesheet exporter to return to its former patch glory.

My best guess is the animations that wont export would make an image too big for Spriter to handle. I suggest you export those as sequential images and try a program to stitch them into a sprite-sheet. 
Maybe this: http://spritesheetpacker.codeplex.com/

 

cheers.

-Mike at BrashMonkey

Link to comment
Share on other sites

On 2/6/2016 at 6:17 AM, bwwd said:

This bug causes big problem when i have a lot of work done and i want to change a bit rotation of torso bone on time 300, if i move it then all limbs parented to torso will be keyframed on time 300 as well , this is not what i want cause its messing up smooth s curve motion between 2 keys when additional 3rd key is inserted on all limbs because i moved torso bone, i want only torso to get keyframe , not its limbs.

On 2/6/2016 at 10:48 AM, germanmolto said:

Same here... Also, when copying and pasting keyframes sometimes it pastes the entre keyframes from that máster keyframes instead of the ones I copied.

@bwwd and @germanmolto The issue with children being automatically keyed is fixed for the next version, at least it appears to be.  germanmolto, I believe the other issue may have been related to that, so please test when the next version comes out and let me know if you still have the issue.

Link to comment
Share on other sites

WOW youre serious ? keyed child bones fixed ? Thats fantastic if its true, i was suspecting it was the nature of spriter and could never be fixed, any date for releasing next version ? :-D

Also when i have keyframes on time 300 for example and i remove all of them  then main keyframe still stays there, its not removed.that creates messy timeline and confusion after awhile, it should detect that there are 0 keyframes at 300 anymore and should remove main  top keyframe.main keyframes stays when you remove all keyframes from your bones/sprites or skins.I know that technically you should also remove main keyuframe yourself but it should disappear itself if theres 0 keyframes below it.

My last concern is ability to select multiple keyframes and apply S curve to them.Or better yet, some switch on/off setting that creates S curve instead of default linear curve for all created keyframes - that would ultimately let us switch it on/off, wouldnt even require us to create S curve.I dont know which option is easier to implement, im rarely  using something else than S, depends what physics i want to emulate but for animating living creatures its only S curve and linear. 

Link to comment
Share on other sites

  • lucid unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...