Jump to content

Spriter R6 Bug Thread


lucid
 Share

Recommended Posts

3 hours ago, lucid said:

@bwwd and @germanmolto The issue with children being automatically keyed is fixed for the next version, at least it appears to be.  germanmolto, I believe the other issue may have been related to that, so please test when the next version comes out and let me know if you still have the issue.

Indeed Lucid it is fixed. You are awesome. Thanks!

Link to comment
Share on other sites

On 2/9/2016 at 2:41 PM, bwwd said:

when i have keyframes on time 300 for example and i remove all of them  then main keyframe still stays there, its not removed.that creates messy timeline and confusion after awhile, it should detect that there are 0 keyframes at 300 anymore and should remove main  top keyframe.main keyframes stays when you remove all keyframes from your bones/sprites or skins.I know that technically you should also remove main keyuframe yourself but it should disappear itself if theres 0 keyframes below it.

The reason it doesn't automatically delete the mainline key is because the mainline key could still potentially have information for zorder and hierarchy changes.  This will be handled more nicely in Spriter 2.

On 2/9/2016 at 2:41 PM, bwwd said:

My last concern is ability to select multiple keyframes and apply S curve to them.

It's not exactly what you asked for, but the next version will have the ability to apply speed curves to multiple keys at a time, and also to copy speed curves and paste them to one or more keys.

On 2/9/2016 at 6:09 PM, germanmolto said:

Indeed Lucid it is fixed. You are awesome. Thanks!

You're welcome, and thanks for saying I'm awesome, but the fix hasn't been released yet. :)

On 2/10/2016 at 7:54 PM, bwwd said:

Do you have new version with this fix ?

See above.

Link to comment
Share on other sites

Great news ! Applying curve to multiple selections will speed up work a lot ! 

Having S curve to select from that small menu would be great as well.there is only instant,linear and custom, would be nice with instant,linear,S and then custom, like here :

nGwDheb.png

Aaah i see now, main keyframe contains data about z order , and having linear keyframe of image swap between 2 keyframes with S curve doesnt mess up their rotation and its still smooth, thats nice.I didnt tested it like that.Keying z order keys only z order and keying image swap keys image swap only, thats why i was confused when moving parent bone keyed rotation of child bones as well.

Link to comment
Share on other sites

Hello,
I use the plugin to Sprinter with Construct 2.

Everything works fine when I do previews, but when I export nw.js with the sprite of my character does not appear on screen. Finally one out of three times yes ...

I did a lot of testing, Spriter object is present on the screen, to the right position on the right layer. It is visible in the properties and moves along the Spriter movement but does not appear on screen.
I do not understand ... this rather mysterious.


Thank you in advance
Jerome

Link to comment
Share on other sites

21 hours ago, Ransom said:

As of this release, nudging objects via the arrow keys does not work for the down arrow; this changes keyframes now.

It's working for me.  What platform are you on?  And can you please check if turning on/off NumLock makes a difference.

11 hours ago, Christopher Artuan said:

"Copy selection to All Frames" (Ctrl+D) feature on the edit menu does not work anymore.

Thank you.  This is fixed for the next version.

3 hours ago, hieronims said:

Everything works fine when I do previews, but when I export nw.js with the sprite of my character does not appear on screen. Finally one out of three times yes

This will be difficult to troubleshoot without the actual project to work with.  If you don't mind, please send us the c2 project (and preferably a zip of the Spriter project as well) at mail@brashmonkey.com.

Link to comment
Share on other sites

10 minutes ago, lucid said:
21 hours ago, Ransom said:

As of this release, nudging objects via the arrow keys does not work for the down arrow; this changes keyframes now.

It's working for me.  What platform are you on?  And can you please check if turning on/off NumLock makes a difference.

I'm using OSX El Capitan, v 10.11.3. Num Lock isn't an issue (actually absent from keyboard.)

Link to comment
Share on other sites

Quote

This will be difficult to troubleshoot without the actual project to work with.  If you don't mind, please send us the c2 project (and preferably a zip of the Spriter project as well) at mail@brashmonkey.com.

 
It will be quite difficult because my project is pretty huge and mostly private .

But I'll make it a little more and send you the link to the file capx .

Have a good day
Link to comment
Share on other sites

  • 2 weeks later...
On 2/25/2016 at 8:55 PM, Ransom said:

Getting frequent, but irregular crashes when attempting to open an .scon

 

Hi Ransom,

Sorry to hear you're experiencing crashes. Please answer the following:

Is it one specific scon file or any scon file?
Are the images quite large and are there many of them?
Do the crashes occur if you save the file as scml format instead and reload it as scml?

What OS and general system specs are you running Spriter on?

Thanks.
-Mike at BrashMonkey

Link to comment
Share on other sites

On 2/27/2016 at 4:24 PM, BrashAdmin said:

 

Hi Ransom,

Sorry to hear you're experiencing crashes. Please answer the following:

Is it one specific scon file or any scon file?
Are the images quite large and are there many of them?
Do the crashes occur if you save the file as scml format instead and reload it as scml?

What OS and general system specs are you running Spriter on?

Thanks.
-Mike at BrashMonkey

 

1) It seems to happen on any .scon

2) Art is generally 100px or less. However, many art pieces feature large areas of transparency reaching up to 400 px, though.

3) Crashes happen upon opening .scml and .scon files. We are commited to the .scon format for this project, though, so I'm not sure if these crashes happen at the same frequency.

Running OSX El Capitan, v 10.11.3

MacBook Pro (Retina, 13-inch, Late 2013)

Processor 2.4 GHz Intel Core i5

Memory 8GB 1600 MHz DDR3

Graphics Intel Iris 1536 MB

Can provide crash report if you want. (It's long, figured I'd ask before posting.)

 

Link to comment
Share on other sites

Thanks very much for the info. Would you mind zipping up the entire Spriter project (images and scon file) and email it to lucid@brashmonkey.com ?

This way Edgar can see if he can reproduce the crashes or find any issues in the scon file itself.

Please copy your original post into the email with the file to remind Edgar of the issue.

(of course we wont share the files with anyone and will delete them immediately after resolving the issue.)

 

cheers.
-Mike at BrashMonkey

 

 

Link to comment
Share on other sites

  • lucid unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...