Jump to content

Spriter B10 Bug Report Thread


lucid
 Share

Recommended Posts

As some of you know, I'm not a fan of image deformation in animation; because too often you get what I call: rubber-band animation (not always though, and when used sparingly it is a really powerful tool). And that is also one of the reasons why I haven't played around with it over the last several versions (I looked at it shortly when it was first implemented, but that's about it).

However, based on bwwd's posts I decided to look whether this experimental feature was as problematic on my system as it is on his. So here are my experiences:

1. when I add an object as a skin to the project, and immediately delete it, then it will move to the (0,0) position of my project and be stuck there. I can't move it anywhere else...but I can still rotate the object. Doing so will, however, crash Spriter.

2. when I add an object as a skin and double-click it to go into skinning mode; do nothing, and then delete it, then it will be gone from my canvas...but still be in my z-index pane.

3. adding a segment will also create a name element in the z-index pane. This might be intentional, but it just seems weird to me.

4. when optimizing my control-point positions my image sometimes disappeared from the canvas.

So while image deformation has to me personally a VERY low priority, I understand and agree with some of the frustrations bwwd is venting. The problem isn't the feature in itself, or even its rudimentary user interface...but the fact that after less than an hour I said to myself: I can't set up a sample project to even test this feature and give feedback. And if I were bwwd, and would consider this an essential feature for my approach to animation, this would be reason enough to move away from Spriter; which would be a shame.

Just my thoughts...

edit: I also get the same crashes when using bwwd's project file and first select the upper part of the character head (whead.png) and then the jaw (wjaw.png) with the head still selected.

Link to comment
Share on other sites

edit: I also get the same crashes when using bwwd's project file and first select the upper part of the character head (whead.png) and then the jaw (wjaw.png) with the head still selected.

Thanks for testing and confirm of the bugs so its not like its only on my computer, it is possible to create animations using deformation but you have to be very very careful ,save after every change and before clicking on something you have to click on empty space to deselect everything, you must do this all the time to avoid crashes.I have other problems you mentioned too but i just avoid deleting stuff like this, biggest issue for me is problem with simple task like selecting different skin.

I can understand that some of the problems might take more time to fix but select bug is really one of the first ones which should be fixed long long time ago, 10 months with no improvements on this part of the code is a lot, almost entire year and "wait till after 1.0" is always repeated but im not really asking about making it perfect and fixing all the bugs, just the basic one with selecting which is responsible for 90% of the crashes and if i see that it can be fixed simply by deselecting everything or selecting everything and selecting again then its just weird that simple solution isnt still implemented.Even simple thing like pressing Ctrl+ A between every step you do in spriter helps to avoid crashes, very simple hack could be implemented in a couple of minutes to "fix" this but no, what for .This isnt big stuff and i feel quite bad about bragging about it on forums , then i checked that its 10 months since were being told its experimental , I didnt really had chance to test deformation in spriter cause its not accessible in demo mode and didnt know how often its crashing, so i had to buy spriter to even try it.You can kinda guess how i felt about it.I have fps drop in recent version as well, its quite visible , animations arent so smooth anymore.

Link to comment
Share on other sites

I found a bug. Updating pivot points don't update anything :(

I'm using files from B8.

Edit:

NM. The pivots upadte. but the the sprite center point as to where I thought it would be drawn from isn't. The pivot points also seem to be based on the animation key. Where I though moving the pivot point on the graphics image would also set the graphical position of the sprite for all animations.... which is what I was hoping for :(

Link to comment
Share on other sites

  • 2 weeks later...

When I first start Spriter, and load/create a project, the right-click menu pops up when I use the middle (wheel) button to pan the view. It also starts happening after you select one of the right-click menu items. In either case, when you left-click the canvas, it stops happening.

(Windows 7 Ultimate 64-bit, generic Logitech USB 3-button mouse. I have a Logitech M310 wireless coming in the mail; will test again when it gets here)

Link to comment
Share on other sites

Spriter crash on start. :(

(spriter.exe has stopped working)

Windows 8 64bits

Intel core I7 - 3630QM

12Go RAM

Intel HD4000

Geforce 650M

tried to run it in win7 compatibility mode, and with admistrator rights, but still crash.

Hi kratapouet,

I run Spriter on my windows 8 64 bit computer just fine... so there must be something more specific causing you the issue. Have you tried re-downloading and reinstalling? Where are you installing Spriter to? Which version of Windows 8 are you running? Is there any other thing you can think of that makes your set-up/OS not typical?

Thanks,

Mike at BrashMonkey

Link to comment
Share on other sites

This is for Spriter version as of yesterday.

-When using a low screen mode (like 1024x768) the full window doesn't cover the timeline very well and you cant input a number in the timeline (Streching and frame number option). Switching to a higher mode works ok.

-Selecting a 0 scale sprite and then changing the scale to some number in the numeric input crashes 90% of times.

Link to comment
Share on other sites

Hi Spriter team, I use spriter release b10 on Windows 7, and there is the same old bug with the tags :

etc... sometimes it stop at t=127, 255, 511, 1023, 2047... and so my .scml file has a size of 60Mo !

The bug happens when I use tag with my anims, adding them or removing them, I don't know...

Have you an idea of how avoid this bug by using Spriter ?

Link to comment
Share on other sites

I also get this bug:

"The program can't start because vcomp100.dll is missing from your computer. Try reinstalling the program to fix this problem."

I have an Intel i5 processor and a fresh install of Windows 8.1.

I also performed the following:

- Uninstalled Spriter B10/Reinstalled B10

- Installed Visual C++ redistributable 2010

- Reinstalled B10 - still got error.

- Verified that vcomp100.dll is present in C:/windows/system32

Link to comment
Share on other sites

Hi there,

I just installed B10 on my system. I am running a Macbook Pro 17" with Mavericks. The screen opens looks like this (with about brought up)

https://dl.dropboxusercontent.com/u/699 ... riter1.png

then when i make a new project i get this:

https://dl.dropboxusercontent.com/u/699 ... riter2.png

When I go to exit the program because there is nothing I can do it int. I get this error "spriter quit unexpectedly" and a bunch of code which I've recorded, but not sure would be wise to paste in here.. :)

Link to comment
Share on other sites

same old bug still there preventing spriter to even start

linux64

[fox@darkstar SpriterB10(64)]$ ./Spriter

./Spriter: error while loading shared libraries: libMagick++-6.Q16.so.5: cannot open shared object file: No such file or directory

is it /usr/lib ?

...

here is the fix for anyone unable to start spriter on linux atm:


sudo su
cd /usr/lib
ln -s /usr/lib/libMagick++-6.Q16HDRI.so libMagick++-6.Q16.so.5
ln -s /usr/lib/libMagickCore-6.Q16HDRI.so libMagickCore-6.Q16.so.2

Running Ubuntu 14.04 ... I installed its libmagick++, but had to do the symbolic links differently:


cd /usr/lib
ln -s x86_64-linux-gnu/libMagickCore.so libMagickCore-6.Q16.so.2
ln -s x86_64-linux-gnu/libMagick++.so libMagick++-6.Q16.so.5

On Ubuntu 14.04 x86_64, after creating symbolic links :

./Spriter: error while loading shared libraries: libMagick++-6.Q16.so.5: cannot open shared object file: No such file or directory

What the **** ?

Link to comment
Share on other sites

  • 2 weeks later...
same old bug still there preventing spriter to even start

linux64

[fox@darkstar SpriterB10(64)]$ ./Spriter

./Spriter: error while loading shared libraries: libMagick++-6.Q16.so.5: cannot open shared object file: No such file or directory

is it /usr/lib ?

(...)

those should take about 3 extra megs if bundled with spriter. Not sure if that would be the greatest solution though. Not all linux users are tech savy enough to fix it with a symbolic link. It is a pain in the ass tbh. Hope this doesnt happen to ubuntu users. manjaro might just have a weird version of imagemagick

Indeed, there's a lot of dependencies that will prevent Spriter from starting out of the box on almost every Linux out there (tested on Ubuntu 10.04, 12.04 and 14.04, failed on all of them), and most of those libraries should be bundled with the application. Once I made Spriter work on my Archlinux, I took the liberty of packing it up as an AppImage, and uploaded it here.

It's a pretty big package (37.50 MB) compared to the original package (Spriter_free32.tar.gz, 3.3 MB), but it's not really that big for today's standards on Internet speed and storage capacity, and it should create a much better user experience (at least it works out of the box on 32bit Ubuntu 10.04, 12.04 and 14.04 LiveCDs). Besides, it packs even the static linker in a overzealot attempt to make the package as portable as possible, but other people usually just build the app in an old enough distro and pack only uncommon libraries (like libMagick++ or libQt*) while keeping common ones (like libc), or build static binaries (like the Godot engine (which I hope Spriter supports in a future!!) guys, that pack just one static binary without dependencies (although if you use Qt you can't link statically without an expensive pro license, so bundling the libraries along with your app would be the only way)

Link to comment
Share on other sites

I just bought Spriter, and I love it. It's such an awesome tool, and I'm currently building my first animation! :)

However, there is a bug that happened because I chose to work with very high res images. When I doubleclick an image in the palette that is very large in size (923x1024), i can set the origin point, but can not close the window. My screen is 1680x1050, so I guess I was very close to the limit.

Quick workaround would be to let me double-click to set my point and close the window. That would also be faster for images that are normal in size. Oh and I just figured, pressing enter would also save my selection.

Thanks! :)

Link to comment
Share on other sites

Some other bugs/suggestions:

I have a hard time to see the playhead when skipping with 1/2 or the buttons, since the little arrow/line sticks on each frame and is not refreshed. If i click and drag it works better.

Is there a shortcut for play/paus? Why not Space, usually standard in video editing?

Also on the easing feature, it would be great if there were ease-in, ease-out presets. I find that easing does a lot to create nice animations!

Link to comment
Share on other sites

Another bug (i think), when I see all parts of an animation, and drag the key for a specific bone, there is still a key on the main timeline, which doesn't seem to be attached to anything.

See screen, the orange one was just moved a bit to the left, and that bone was the only keyframe on that position.

9Gz1wA1.png

Link to comment
Share on other sites

Sorry for finding all these small bugs, but here's another one :roll:

If you're working with adjusting position and easing on a keyframe for a specific bone, and tap 1/2 (skip time), the timeline scrolls to top, so you lose focus on what you were doing.

Is there some acknowledging to the bugs, should I still report more if I find? :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...