Jump to content

B6.1 Bug Thread


lucid
 Share

Recommended Posts

Two issues to report. I hope I'm not annoying you with repeats of old issues, but I've not seen these particular things mentioned before:

I'm using Windows 7, screen resolution 1024x768, and when I run in maximized mode, the timeline toolbar is not sized properly to fit my screen. I can only see the full span if I use windowed mode or undock the toolbar. This incorrect sizing makes it impossible to adjust the length of my animation when in maximized mode (I can click the current time 'maximum frame' button to change the length, but I can't get the edit text field). As far as I've noticed, this only happens with the animation timeline bar.

Also, I've noticed something wrong with the copy/paste keyframes functionality. If you have nonlinear speed curves on any of your keyframes and use copy/paste, the speed curves of the pasted frame and all frames past that point may be messed up. What seems to be happening is that speed curve information isn't being saved with the copy function, so when it's pasted it just overwrites the next value in the list. And that sets all later speed curves back one frame as well.

To clarify, it's like this

Before copy/paste

Key 1 - linear

Key 2 - instant

Key 3 - linear

Key 4 - linear

Key 5 - bezier

Key 6 - instant

After copy/paste

Key 1 - linear

Key 2 - instant

Key 3 - linear

Key 2 copy - linear

Key 4 - bezier

Key 5 - instant

Key 6 - linear

Update: Upon closer inspection, this effect seems to occur when a keyframe is added for any reason, and not just copy/pasted frames. Also, the undo command does not appear to fix the curves involved.

Link to comment
Share on other sites

  • 2 weeks later...

I'm not sure, if this one already have been posted.

When I won't run spriter on "admin mode", change something, and hit ctrl+s,

the save option is greyed out(because after the save, nothing changed). After reopen the scml, no changes were applied,

but spriter didn't told me, they weren't any rights to save the file. Spriter is installed at "c:\". The scml is on another hd.

Win 7 prof. 64bit.

Link to comment
Share on other sites

  • 3 weeks later...

I am having a couple of issues with Spriter in C2 still. I suspect the first error is in how C2 works. I may just have to make a mirrored version of the Spriter animation. Here's what it does when I'm creating this flame-thrower-like effect--first it spawns, then flips: https://dl.dropboxusercontent.com/u/60595907/psiclip1.avi

Here's the code I'm using:

Screenshot%202014-03-07%2012.59.06.png

I've tried it a few different ways and they all have this same effect.

The other ongoing problem I've been having is when I spawn some Spriter attacks, this error pops up:

Screenshot%202014-03-07%2013.20.18.png

It seems that there's some sort of error in giving certain Spriter objects an IID.

AMD Phenom II N970 Quad-Core Processor, 2200 Mhz

AMD Radeon HD 6470M Graphics card

8 GB DDR3 RAM

Windows 7

Link to comment
Share on other sites

Hi PSI,

Is it me, or are you trying to flip an object that hasn't been created yet?

You need to make sure the actions create the object first, then flip it if need be.

That said, I fixed that order i nthe capx you sent and there' still issues with the flame not always flipping as it should. I'll keep digging and report back.

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Everytime I try to export to .PNGs, they come out looking scrambled! The sprites show up in each image but the transparent areas look layerd or somthing.

I have the same problem here (Mac OS X 10.9.2, Spriter b6.1).

Since you are using Qt, you are probably experiencing this issue (QImages are generally not initialised after creation):

http://stackoverflow.com/questions/1346 ... -has-noise

So, this might be all you have to do after creating a QImage and before drawing the individual bitmaps onto it:

image.fill(Qt::transparent);

I also tried to export my project under Windows XP which resulted in a crash..

Finally, I tried it under Linux which worked flawlessly. This might just be a lucky 'coincidence' due to differences in memory handling though.

Anyway, thanks for a great tool. I can't be bothered with single-platform tools anymore these days, so I was very happy to find your project.

Link to comment
Share on other sites

I dont know if it counts as bug but you cant select multiple skins and move them all at once, or select only legs skins and move them both leaving other skins in place. I wish it would be fixed in new version cause its hard to move them one by one and keeping them alligned properly.

Link to comment
Share on other sites

Hello, here's my bug/suggestions list.

SCML:

[list\]

1. Key duplication in saved file:



--- few keys aren't shown













Usually if there are many keys with the same time the last one referenced by the timeline and the rest not referenced by anything - meaning producing garbage.

2. Folders info duplication
















...

Mysterious folder "0" is not actually a folder.

3.SUGGESTION Save only used files in scml. Benefits are less file size, more version control friendly(adding unused file into a folder doesn't lead to scml changes).

TIMELINE.


  • 1. Keys copy pasting has some issues:
    - Sometimes bone parenting not pasted correctly
    - Sometimes Z-order messed up
    - Sometimes if you try to deleted just pasted key there are some keys on the timeline(Most likely it's garbage keys from scml #1)
    - Cross animation copy/paste gives unpredictable results.
    2. Timeline UI shows sliders even when content fits the window. (Vertical is the most annoying because it makes it harder to select the key at the end of the timeline)
    3. Timeline UI doesn't use whole window space if big enough. Basically I expanding to ft my second display but it refuses to use it optimally.
    4. Shortening the timeline won't delete unreachable keys
    5.SUGGESTION Lock keys button to lock the timing (not the key's others properties).

OBJECT PROPERTIES


  • 1. Seems that ui only updated when selection(in Hierarchy/Z-Order) is changed. However when animation time is changed ui remains the same.

PREVIEW PANEL


  • 1. Changing Z-order won't affect preview render until user is clicked on preview area.
    2. SUGGESTION Make preview panel draggable
    3. SUGGESTION Have a functionality to center the camera to a sprite

BONES PANEL


  • 1. SUGGESTION Changing parenting may not need to expand the whole bone tree
    2. Sometimes refuses to copy/paste bones

ANIMATION PANEL


  • 1. SUGGESTION Sort animations alphabetically

Z-ORDER PANEL


  • 1. Dragging a bit confusing, but you get used to that after some time.

EXPORT:


  • 1. SUGGESTION Save last export location/ preferences
    2. Onion skinning/ bone selection gets exported into final render
    3. SUGGESTION Add export progress bar.

OTHERS


  • 1. SUGGESTION Save panels positions. Have an option to restore default positions.
    2. SUGGESTION Auto save into temp file. Prompt to restore changes after the crash.
    3. SUGGESTION Make all draggable windows expandable. Annoying to do this by hand.
    4. SUGGESTION Mark (*) when project have unsaved changes.
    5. *Thinking loud* You receive crash reports, right? Seems to have some stability issues, crashing after some work spend.

Link to comment
Share on other sites

1. Sometimes when changing a bone's parent other bones may disappear from hierarchy view.

I had this skeleton:


bone_1
- bone_2
-- bone_3
-- bone_4

I attached bone_3 to bone_1 and bone_3 disappear from view. Workaround is to reload project.

2. Zoom-in/out in timeline view behaves incorrectly in certain situations:

- when ui shows full timeline

- when slider been moved significantly

The behavior is wrong meaning that zoom pivot point is not under the cursor. The consecutive zooms behave correctly.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...