Jump to content

Please post bugs here.


Recommended Posts

@ jcmeyer5

Fear not, there will be other features to eventually give very easy control of animation duration etc. And the goal is to make the interface as easy to use as possible, sometimes this means numbers are critically important..we're not avoiding them, they're just not in yet.

Also, the transform gizmo will be improved to ensure very easy use. Right now the biggest issue is that it ends up behind sprite images in z-order, making it sometimes impossible to perform certian transforms on he selected sprite without accidentally selecting the one above it.

cheers,

Mike at BrashMonkey

Link to post
Share on other sites
  • Replies 110
  • Created
  • Last Reply

Top Posters In This Topic

Spriter 8/17/12 build

Using Win XP 32bit

Using my default character which includes 26 sprites.

If I save a single frame to the D: drive in the folder above the images when I load it back up the File Palette loads up correctly, and the Objects in Frame list will list the correct images and attributes, but the thumbnail image is absent. You can view the sprite details, but clicking to select a sprite will crash the program. There is also nothing showing in the Scene window.

If I save a single frame to the default Spriter folder I can reload the single frame, and everything comes up correctly with two exceptions. The highest Z level sprite is in the wrong location, and just under it the lowest Z level sprite has been duplicated.

Saving seems to work in the default directory as long as there is at least two frames, but upon reloading there is now a gap in the animation when looping. (There also seems to be an issue with two pivot points being altered during the animation slightly.)

Manually adjusting the scale in the OiF menu after using the Scene window tool crashes the program.

After grouping items the pivot points on the individual sprites get weird for a bit. Once I had the sprite start orbiting the pivot point and when trying to move them they would float back into the same relative starting positions. All the funny business goes away after activating another sprite, and then returning to the offending sprite.

Once I get over 11 items the Z order stops defaulting to the top randomly when new items are added.

Link to post
Share on other sites

thanks soho,

if you don't mind sending me the entire folder structure as a zip file, I can try to duplicate the problem with the sprites not loading correctly.

After grouping items the pivot points on the individual sprites get weird for a bit. Once I had the sprite start orbiting the pivot point and when trying to move them they would float back into the same relative starting positions. All the funny business goes away after activating another sprite, and then returning to the offending sprite.
what do you mean grouping items? do you just mean selecting them?
Link to post
Share on other sites

Sure, I can send you the goods, but I think I only have Mike's email. I checked your profile, and didn't see an address there. (EDIT: Just saw your email in the A2 Beta thread, I'll send the files over.)

For what it's worth (and to help explain a bit more beforehand,)

I first tried the D: location (my storage/secondary HDD) as: "D:\GameDevelopment\Wendie's Game Scratch Area\Concept Art\Character Files\Little Girl A2" In that folder I had my test SCMLs, and a folder "Spriter" which contained the sprites.

I then moved things to: "c:\Program Files\Spriter" (program default save folder) The folder contained the SCMLs, and the image folder "Spriter" as well.

I have been using: "D:\GameDevelopment\Wendie's Game Scratch Area\Concept Art\Character Files\Little Girl" with the original BrashMonkey Spriter beta build, using the same file/image folder setup.

I have continued playing with it, and when saved in the C: location only the first save moves the highest ordered sprite to the wrong location, and duplicates the lowest. If you then fix things, and save again the position is not messed up again, only the duplication problem continued.

When animating, after a few frames the sprites seem to loose their place and move around. Much like the first beta did when you left tweening on, and changed something.

-----

By grouping I was referring to selecting multiple sprites in order to move them as one. In the previous version available from the site you could do this, and create a group on the right. I am still doing this in the newest beta, I just have to reselect and adjust the anchor/pivot point on the sprites manually each time.

The following picture shows what I mean exactly just to clarify, and also at the bottom of the Objects in Frame tree you can the the duplicated top sprite the "Rear-Hand.png" It has been duplicated and place at (0,0) in the frame/scene below the character feet.

spritertestimage1.jpg

Link to post
Share on other sites

When trying to delete a frame of animation, I press the delete key after clicking on the frame, and the application crashes to the Windows 7 "This application has stopped working..." dialog. Animation used for testing was the example monster file.

Link to post
Share on other sites

Hi Brashmonkey

New user here and I like what I am seeing - very cool program.

When I move a .png from the file palette into the canvas for the first time two instances of the image appear (both in canvas and in "Objects In Frame"). This would only be a slight bother except that deleting doesn't always work. Of three images I was working with, the two that were imported on frame 1 did not respond to delete either from the toolbar or the Edit dropdown menu. A third image that was not brought in until a later frame could be deleted just fine.

Mac OSX 10.6.8 | Spriter downloaded 8/24/2012

Link to post
Share on other sites

I'm on a Macbook Pro and I was using the trackpad. I hooked in my PC mouse to test and the problems are the same: duplicate creation and inability to delete. Also of note: I experimented further and even images that are not created on frame one usually refuse to delete. I'm not sure what it was about that original image that allowed me to delete it, but it was not the delayed creation.

I'm going on vacation, but when I return I'll try reinstalling just in case I've got a corrupted file causing these issues or something.

Link to post
Share on other sites

Just a little random thing I noticed (not quite a bug):

When you hover your mouse over the timeline buttons, only the "Next Keyframe" button pops up a bubble saying what it is and with the status bar also saying "Skip time to next keyframe.". None of the other timeline buttons pop up a bubble or show a message on the status bar.

Link to post
Share on other sites

I've just had Spriter crash on me several times and each time the file I'm working on breaks. Last time it happened (just now) I'd been careful. I'd saved the project as a new file at each critical step (so far I was up to three different savefiles). Soon enough it crashed again, and all of the files I had saved were broken. I can't recall the specifics of each crash (because I haven't slept and am tired) but they seem to either happen when I'm changing the order, doing something with the keyframes, or manipulating the graphical assets.

Link to post
Share on other sites

A few private forum members who were having issues with frequent crashing have contacted me saying they are no longer having stability issues in the latest builds, so there's a good chance whatever caused those crashes has been fixed. The next release will be in the next few days.

Link to post
Share on other sites

Seems like currently the most common crash source for me relates to deleting key frames.

Usually once the last key frame is deleted, either after adding one new object or just right there, some ghost UI elements appear on the left as there was some empty object left in the list and crash.

Link to post
Share on other sites

I'd actually forgot about that forum. Downloaded the latest one and tried opening my (supposedly) broken files. It opened without issue. Weird.

It still managed to crash eventually though (was deleting keyframes and I think you specifically mentioned fixing that somewhere), but at least the file didn't "break" this time.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...