Jump to content

Please post bugs here.


Recommended Posts

Hi everyone.. Please post your bugs in this thread and I'll Edit this top post to always reflect all nkown bugs and their curent status.

Thanks much.

BUGS

FIXED On starting, the frame preview window isn't set properly to the default prefs.

FIXED X close (top right corner) button doesn't close the app.

FIXED Window's tab right click doesn't close the app.

FIXED Scrolling Charmap stuff ugly

FIXED Loads in desktop folders of you cancel out of load or create!

FIXED On rename anim, it warns if you don't change the name, just exit out if its the same

FIXED Key pressing for opacity change broken for multiple selected objects.

FIXED PREFS dialogue box doesn't reflect data perfectly upon opening it.

FIXED When deleting frames, clear frame editor and show the “No frame selected”

FIXED If only one frame is selected and user flips or mirrors, UPDATE FRAME!

FIXED Clear anim preview on clear all and etc.

FIXED LOTS of Issue with editing deleting one of multiple sounds for a frame. (list refresh)

Link to post
Share on other sites
  • 3 months later...
  • Replies 110
  • Created
  • Last Reply

Top Posters In This Topic

The width and height numbers displayed in the part info behaves strangely when you + -(with keyboard or buttons) showing values of 3 decimals for example a 54 pixel with will be 541 and a 9 would be 956(floats?)

Also when you set it up a value(by entering the numbers) any + - will use the previous + - values including reseting to previous w h

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...

@telles0808,

Would you be willing to send me one or more of these PNG files that dont load properly. I'm guessing whatever is creating your PNG files is creating them in a format that Spriter can't handle properly. Have you tried converting your PNG's (load them into a diferent image editor and then save them back out)?

Whould you also mind telling me what created the PNG's that spriter can't load properly?

Thanks much

Link to post
Share on other sites
  • 8 months later...

Hello!

The images was created using Fireworks, saved in 256 colors with alpha channel (transparent).

I bought the early adopted version, when I'll get into the alpha? =P

-----------------

Another issue is about the windows size and his configuration.

I hate to re-configure everything every time I close the software and re-open it.

Look what's happening, all the windows are overlapping my Windows Bar.

http://dl.dropbox.com/u/47035927/windowssize.png

----------------

Using the PRO 0.83 version, if you create a new project, it will bug, because the saved file need an "image" folder to stop flashing the "map" menu. Unless you create this folder, it keep flashing, and using windows memory, freezing the windows.

Link to post
Share on other sites

Hi telles0808,

About the PNG's... unfortunately there's no way I can change the current Spriter to support PNG's that it doesnt currently work with.. I'd suggets using a free program perhaps like Irfanview to convert them to a standart 24 bit PNG. Sorry for the inconvenience.

As for the window issue..sorry, I had totally neglected to consider vertical windows bar. Have you tried saving your windows arangement? Worst case senario you'll just need to load the settings when you boot.

As for the Alpha version for testing..As a Spriter Pro Purchaser, you should have received an email with links related to downloading the alpha version and reporting bugs and feature requests. If this has not happened, please email mail@brashmonkey.com with the email associated with your paypal payment and I'll make sure you get the links ASAP.

Again, sorry for the inconveniences and that you very much for your support.

Link to post
Share on other sites
  • 4 months later...

I'm running Win7 x64 Business, and I have my taskbar located at the top of my screen instead of the bottom. When I open Spriter, it opens to the full extents of the screen without taking taskbar placement into account. This puts the menu bar and window controls underneath my taskbar. If I move my taskbar to the bottom of the screen, the Spriter window moves up, which puts the menu and window controls off-screen. Additionally, the standard Windows keyboard shortcuts for window controls (alt, spacebar) don't function, so I can't manually move the window into a usable area.

Link to post
Share on other sites

thank you adric. Editor updates will probably be slow or nonexistant during the kickstarter, as promotion and responding to email has become a full-time job. But we'll be back to full-speed after all this is over. But the bug is noted, and on the todo list to fix.

Link to post
Share on other sites

Thanks for the temporary fix wex.

hirunav2, it's definitely not supposed to do that.

Are your graphics card drivers up to date?

Did you download the latest version from Brashmonkey.com (http://www.brashmonkey.com/spriter/SpriterBeta.zip)

Also, though 1.0 will install these for you without additional prompts, the beta depends on these, even if you have a newer version of directx:

http://www.microsoft.com/download/en/de ... x?id=14546

http://www.microsoft.com/download/en/de ... g=en&id=29

If it still doesn't work after checking these things, please post back and we'll dig deeper.

I'll be integrating these into the installer as soon as I can.

Thanks for testing!

Link to post
Share on other sites
  • 2 weeks later...

I doing a livestream of me using spriter the other day when in mid stream a bug occurred(2:10 http://livestre.am/1Hj6W).

To make a long story short, after I exported png images with the animation slider showing previous/upcoming animations(turned out not how I wanted) I deleted them, maximized Spriter, and ended up with text and stuff inside the animation window. It fixed itself after I stopped Spriter and ran it again but it happened again later but also in the png exporter(10:56).

A second bug occurred around the 8:30-9:30 mark when I tried to export it again but only a few of the animation png frames came out. It might have been because I was running the animation at the same time but I can't say for sure.

A minor but weird bug(maximizing window) happened at about 10:07 in the stream but nothen to be to concerned about.

My system specs are intel 2.66 dual core cpu, 4gb ram, win7(32-bit) OS, on a Dell Latitude D520.

I hope this helps you guys with making Spriter. =)

Link to post
Share on other sites

sorry for the slow reply blazah. Some strange bugs indeed. After the kickstarter dies down, the first thing I'll be doing is some general code maintenance, which should make everything more stable and efficient. If things like this are still happening, I'll dig deeper.

Link to post
Share on other sites

Using Beta R5, frames are getting "linked" where changes in one affect changes in another. It looks to be related to copying a frame, pasting it, then editing the new or original frame changes both. This is happening with frames in between the original and copy.

Link to post
Share on other sites

Spriter windowing behavior on startup is in error. I normally keep my taskbar on the top of the screen. When Spriter starts up, the window controls (the program, minimize, maximize, etc widgets) are inaccessible. Moving the taskbar causes the program window to move and I still cannot access the controls. If you experiment, you'll notice that whatever controls are covered when the program is started remain covered even if the taskbar is moved. I think that needs to be dealt with somehow, even if the program is not maximized on startup.

Link to post
Share on other sites
  • 3 weeks later...

you know that little keyboard short-cut, "CTRL + C"and "CTRL + V".

I just had to try it to see if copying and pasting from clipboard works. (it works)

but when I click on the time line, I paste it, and it gives me a run time error and to report it here.

please make it so that it ignores the paste command when it is not one of those square things in the clip board. :D

I might forget to actually click the drawing area and just paste it there by accident! :oops:

I'm a new user trying out the beta R5. :p

Link to post
Share on other sites
  • 2 weeks later...

Hi everyone. The next release should fix most bugs that exist in the current Spriter, and definitely fixes that cpu issue. The current working build idles at 0% on my PC.

I've been building a much more solid foundation for Spriter for both animation processing and OI. Still a bit to go before release, but it is by far more stable and efficient, and behaves more like you'd expect it to.

Semi off-topic, but are you guys planning on setting up a proper bug/suggestion tracker in addition to the forums, or are you planning to stick with just the forums for now?

It's on the todo-list.

Link to post
Share on other sites
  • 3 weeks later...

Sorry to hear youre having an issue wit hte current beta, moscoquera. Edgar's hard at work getting the totally overhauled UI and cross-platform beta of Spriter ready for release and therefore can't invest time to fix such anomilies for the soon to be obsolete beta.

Your image link seems broken. Maybe if we could see the issue we might have an ideal to fix it...

Have you tried running at a diferent resolution, compatibility modes etc?

I hope we can get it working for you asap.

cheers,

Mike@BrashMonkey

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...