Jump to content

Rotating bones and sprites doesn't key right


Recommended Posts

Maybe it's just late, but I am having no luck figuring this one out! >_<

I'm making an animation currently with only two keys, the starting key frame and the ending key frame. When I move sprites or bones on my ending key, everything works as expected. When I rotate the sprites or bones in the ending key, that rotation is also set to the starting key. So my starting pose gets messed up, and no rotation happens in the animation. Even if I delete the ending keyframe, the rotations remain applied to the starting frame.

Any idea what I've managed to do to it? I assume I hit a hotkey or something for some alternate mode.. I've made a few animations before and this has never happened. Restarting the application doesn't help! (Or whatever it is I'm doing wrong, I keep doing it...)

Link to comment
Share on other sites

That does sound very strange. The fastest way to get this figured out might be to record a video clearly showing the issue and post it here or email it to mike@brashmonkey.com

The only other thing I can think of is to go to the first keyframe and click "key all" BEFORE creating the second key frame via rotating things.  This should not be necessary, as the first key should already have a key frame for every single object, but it's currently the only thing I can think of.

Hopefully once I see a video I'll know what to do or have a better idea of things to try.


Link to comment
Share on other sites

Definitely looks like a bug, and a bad one. I think it was introduced in the most recent build. You can revert to previous builds in by downloading and installing them from here: 

Click download file and then pick one of the files below the top one.

I've  reported the bug to Edgar so it can be fixed as soon as he gets a chance.

Side-note... the 1 and 2 key above the letter keys can be used to instantly go back a frame or forward a frame... much faster and more reliable than clicking and dragging to each key frame.

Link to comment
Share on other sites

Well, unfortunately, I tried rolling back to version 9 and 8 and the problem was still present. I tried uninstalling completely too (for what that's worth!) and got the same thing to happen there. I'm guessing it might have something to with the particular object I'm working with, I tried messing with an older character in the same project I made earlier and didn't have any trouble there. I'm sending the zipped project to your email, if that helps to reproduce the bug!

Also thanks for the tip--I figured there must be a shortcut like that, definitely helpful.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...