Jump to content

version B1 bug/crash report thread (and daily Win32 builds)


lucid
 Share

Recommended Posts

Hello everyone,

Please use this thread to report bugs, until I have a chance to clean the bug-tracker of bugs that no longer apply to this build. Things are much more tightly integrated and compartmentalized in a way much more suited to the framework than the previous version. In other words, there shouldn't be a such thing as 'general instability'. If there are crashes, there is a very specific cause. Please help us to find these remaining crashes and bugs, so we can release a fix in the short term. Please report all relevant information including OS, and what exactly you were doing when the bug occurred. This is especially important for crashes. If you can figure out the exact process to reproduce a crash, but can get it to happen often, and you're able to screen record it happening, then I may be able to figure out what caused it.

Thanks for testing everyone.

Daily Builds

Will be updating this thread from time to time with incremental builds. This will not be a forever ongoing daily build thing, but while we squash these first bugs and until we can remove the "pre-" from preBeta, will be posting updates here as I fix things. This should not be considered official releases, and is merely to accelerate the testing/fixing process. Also, when I do this, unless it's a mac or linux specific fix, it will be the Windows version only simply because that is what my development machine is, and building 3 versions for these in-betweens will significantly slowdown overall development. That being said, the arm situation is still ongoing, so I won't give a firm estimate, but there will not be a long delay between official versions again, 2 weeks at the longest. I will post fixes as I need them to be tested, could be multiple times a day, or none at all, whichever makes testing/developing fastest. To install them, simply drop them in the install directory for the current pre-beta.

Link to comment
Share on other sites

Not a bug, but a request anyways...

please oh please let us control hierarchy state. Please keep the current collapse state.

Everytime I need to move objects around and relink bones and stuff. The entire tree expands.... aaaaahhh. It drives me nuts. Please stop this. If I prefer to start with collapsed and expanding as needed. This is the same behaviour that drives me nuts in SWTOR crafting and worse Construct 2 objects.

Everyone stop expanding the tree when I drop something into it :(

Link to comment
Share on other sites

Ah yes, I can fix that. Please remind me in a couple of weeks after we've returned to full functionality if I haven't already fixed it by then. It's basically a side effect of having the model hold the information of collapsed/expandness of each item, and refreshing/reconstructing the model any time a change is made, so it loses that information. Because of this you can either expand or collapse everything, and I think collapsing is definitely the more annoying of the two. It should be a fairly simple fix, though it is a bit tedious, and so it'll take roughly the same time as implementing a missing feature.

I wonder if C2 and the Old Republic have similar reasons or if it was actually a design decision.

Link to comment
Share on other sites

I'm really not sure about the C2. In C2 I can sort of see it. As often you are moving between them. In SWTOR they are very long bland lists. oh well. I guess if some one perefers expanding I'm ok with it. But I prefer that if I collapse a part of the tree for it to stay collapsed :D I can even be ok if it's just the single branch that expands, but it's all the branches that expand that's frustrating :P

Also maybe I'm not understanding the numbers here. But i'm trying to change the X-scale value. Now as I understand it. X is Horizontal -- where as Y is | vertical.

When I change my dragon's X-scale from 0.16 to -.0.16 it flips it up side down or what looks like | verticle change. Is XY-scale reversed or am I just mistaken on how xy-scale translates.

Also I want to say that the stability is really good this time. Also thanks for bringing back the object properties bar. I really needed the alpha for my menu. I didn't mention I needed it as I was sure a new version would come out soon :) and it did :)

Link to comment
Share on other sites

hey jayderyu. xScale and yScale are definitely referring to horizontal and vertical when I test. Remember Spriter has no way of knowing which direction your actual pngs are drawn in, but the easiest way to check if this is working correctly is that the rotation handle is always horizontal with the handle to the right side of the image. Please let me know if it is not functioning that way, along with a detailed run down of system and os specs so I can troubleshoot.

Link to comment
Share on other sites

Hi guys. Back with a new daily.

Canvas item copy/paste is back.

Never explained this before, but the way it works is: If instances of the object(s) are not present in the frame it should paste instances. If instances are already present it should paste clones.

Regardless of whether you copied parent bones or not, or whatever combination of parentage and nonparentage, the items should always appear in the same location overlapping exactly their original location. If any visible shift occurs, it's a bug, please report it.

they should be pasted above(in zorder) all other items in the frame, but maintain their relative z-order to other objects in the same paste.

I haven't tested it extensively. Just gave it a quick cursory test to make sure it functioned, because honestly I'm very anxious and excited to get to the next few features - because once we're caught up, it's time to start progressing to new features again. Also, some of the code for the remaining features to catch up to alpha shares code with those top secret pro features I've been teasing and alluding to over the past few months, and it's very exciting to be back on track with those. So please test this for me, and I will be testing more as well after I get these other features done.

Enjoy:

4/11/13 - 5:34

    [*:be5fshjm]copy/paste in canvas is back

Link to comment
Share on other sites

Also maybe I'm not understanding the numbers here. But i'm trying to change the X-scale value. Now as I understand it. X is Horizontal -- where as Y is | vertical.

When I change my dragon's X-scale from 0.16 to -.0.16 it flips it up side down or what looks like | verticle change. Is XY-scale reversed or am I just mistaken on how xy-scale translates.

Spriter scales first using the pivot point as a reference. Negative values should mirror. After scaling the sprite is rotated by any rotation amount you have specified. Do you have any rotation on your sprite?

Tim

Link to comment
Share on other sites

4/12/13 - 9:30


    [*:38lbis3w]fixed a bug that where Spriter inferred z-order from the ordering in the file. This works fine for Spriter generated scml, but I've since learned that some scml generated outside Spriter doesn't do this, so this should help anyone using converters, exporters, and generators other than Spriter
    [*:38lbis3w]fixed a major performance problem with very large projects
    [*:38lbis3w]added a progress bar for slow loading projects (legacy projects or projects imported from a non-Spriter source that doesn't name every object)

ps: hi timpart.

[edit]at 10:42, fixed the loading dialog to be a proper child to the main window so it looks right now, and doesn't let you hide it by clicking on the main window...didn't think it was worth adding another build though. If any of you actually have projects where you see the dialog, redownload for the fix[/edit]

Link to comment
Share on other sites

Hi everyone just checking in. There haven't been any delays, just working on a feature that takes longer than a day to implement, and haven't gotten to a useful stopping point yet. Please continue to report bugs if you find them. Daily build in the next couple of days.

Link to comment
Share on other sites

Hey, Guys

So, I installed V. B1 today on my Mac but the application won't open. I tried both Spriter and SpriterGL and I keep getting the same error message that reads "This application is not supported on this type of Mac".

I have a Mac OS X Version 10.6.8 (Snow Leopard)

Is there a system requirement page that I may refer to?

Link to comment
Share on other sites

Panther, it should work on any 64bit intel based mac. I will be working to expand that in the near future.

4/18/13 - 2:56

    [*:3ny9rpov]Added a button [...] for animation options next to the play/fast-forward/etc buttons. The right click in main timeline area wasn't obvious to many users, and it was taking up the old shortcut for changing onion skin times. Right clicking on the extra timeline area below for the sub-timelines still brings up the option to view animation properties
    [*:3ny9rpov]Onion Skinning is back. Right click (and hold) to the right or left of the current time indicator in the timeline to set and adjust the forward and back onion skin time. Performance is improved over the previous onion skinning.

Link to comment
Share on other sites

Hello Lucid,

With the latest build I am no longer getting any animation exports via png... I use the PNG exports for prototyping, sizing, etc... but when I point to a directory and export PNG, it goes through the dialogues, but there is never any output in the directory. Previous builds this worked fine for me. Also, any chance to export the series of PNG's as a spritestrip yet as opposed to a series of individual files?

Also I am still seeing a lot of oddities when copying keyframes between animations. The keyframe header (diamond) does not always line up with the pasted keyframes, especially when you delete keyframes, it tends to offset it so it doesn't line up anymore.

Thanks,

BluePhaze

Link to comment
Share on other sites

@BluePhaze,

I've seen them not line up before but I can't get it to happen on command. I'll look into it some more. If you have a reliable way to make it mess up every time, please let me know.

I can add the export to sprite strip at some point, but not in the short term most likely, since we're still playing catchup

I can't reproduce the not exporting, though I found a bug where it doesn't always show the progress bar while exporting:

4/19/13 2:21

    [*:257due2c]fixed a bug where exporting to png wasn't always showing a progress dialog

Everyone, please continue to report bugs, though updates (like today's) will be slow over the coming days as we are completing the infrastructure needed to get pro serial numbers out to everyone and ready to be delivered for new purchases. The good news of course is that features will be appearing soon that require your pro serial numbers.

Link to comment
Share on other sites

Thanks Lucid, I will work on a repro. I did some directory reorganization yesterday and now my project no longer has the imported sprite components. The file pallet still shows the pieces, but the animations and hierarchy windows are now empty though the hierarchy palette shows object_001 - object_009 with no image component next to it and when clicking on them the screen goes blank. My assumption is that since I restructured my directories it is no longer finding the source files that I used when I created the project. Is there any way to reassociate the project with the images in their new location?

Link to comment
Share on other sites

I'm having trouble with the alpha transparencies, if i set a sprite to 0, the sprite then cannot be brought back to 100. The image then becomes unclickable in the canvas and then it also crashes the program when i try to remove it from the hierarchy.

Link to comment
Share on other sites

to crash it, click on the object that is transparent in the hierarchy and then click on it in the canvas (using one of the points in order to resize) then press delete, It freezes the entire program.

Also on another note the copy and paste of keyframes seems to move the bones but not the sprites immediately after the copy and pasted frame. But the strange thing is when i export them it shows the sprites, so it looks like they are there but cannot be viewed in spriter, even after saving and then reopening it is the same thing.

Link to comment
Share on other sites

4/20/13 11:05

    [*:2vnflcii]fixed bug where menubar item text was getting 'highlighted' in black
    [*:2vnflcii]fixed and updated several things for the serial key activation system you'll be using by the end of the month
    [*:2vnflcii]middle click also scrolls in the view now (space bar shortcut also works for people who prefer it or have no middle button)
    [*:2vnflcii]new shortcuts
      [*:2vnflcii]3 to rewind to start
      [*:2vnflcii]4 to toggle play/pause
      [*:2vnflcii]5 to fast-forward to end

    [*:2vnflcii]fixed a bug where you couldn't select or receive hover indications in other views for objects with 0 alpha in the canvas

    [*:2vnflcii]fixed a bug where you couldn't turn objects back up from 0 alpha

    [*:2vnflcii]fixed a crash associated with the 0 alpha problem above

    [*:2vnflcii]0 alpha objects now appear in nearly transparent while hovered to more easily select and manipulate

    [*:2vnflcii]fixed a bug that kept the wrong onion time displayed (red and green)when loading a project after one was already loaded

    [*:2vnflcii]fixed a ui glitch that occurred when loading a project after one was already loaded

Link to comment
Share on other sites

Also on another note the copy and paste of keyframes seems to move the bones but not the sprites immediately after the copy and pasted frame. But the strange thing is when i export them it shows the sprites, so it looks like they are there but cannot be viewed in spriter, even after saving and then reopening it is the same thing.

@Vsquared, can you please forward me the zipped project folder? It would help me figure out the problem.

from last page:

4/20/13 11:05

    [*:18p70eip]fixed bug where menubar item text was getting 'highlighted' in black
    [*:18p70eip]fixed and updated several things for the serial key activation system you'll be using by the end of the month
    [*:18p70eip]middle click also scrolls in the view now (space bar shortcut also works for people who prefer it or have no middle button)
    [*:18p70eip]new shortcuts
      [*:18p70eip]3 to rewind to start
      [*:18p70eip]4 to toggle play/pause
      [*:18p70eip]5 to fast-forward to end

    [*:18p70eip]fixed a bug where you couldn't select or receive hover indications in other views for objects with 0 alpha in the canvas

    [*:18p70eip]fixed a bug where you couldn't turn objects back up from 0 alpha

    [*:18p70eip]fixed a crash associated with the 0 alpha problem above

    [*:18p70eip]0 alpha objects now appear in nearly transparent while hovered to more easily select and manipulate

    [*:18p70eip]fixed a bug that kept the wrong onion time displayed (red and green)when loading a project after one was already loaded

    [*:18p70eip]fixed a ui glitch that occurred when loading a project after one was already loaded

Link to comment
Share on other sites

ah ok there a newest builds here -_-'

i tried the b1 normal

and i had bugs with bones, when you make a new key frame by moving the bone, it always make a new one even if your already on a key frame, so it stacks and makes many keyframes on the same "place" on the timeline

I'd like to know how to put a key frame from nowhere ? i mean without moving a part of the drawing or without copy paste from earlier key frame

also how to use the thing to make smooth animation with png export ?

and if i want to make a part of the body move (by the tweening motion) but i want the head to stay exactly at the same place as it was from the last keyframe, how can i proceed with copy paste ? it didn't work and if i check the angle and position of the body parts it always has the same settings everywhere on the timeline

PS : i need to uninstall previous spriter version before installing the newest ones ??

Link to comment
Share on other sites

ah ok there a newest builds here -_-'

i tried the b1 normal

and i had bugs with bones, when you make a new key frame by moving the bone, it always make a new one even if your already on a key frame, so it stacks and makes many keyframes on the same "place" on the timeline

what do you mean the b1 normal? as in not the latest daily? if so please see if the latest version does this as well. Definitely a bug if so, will keep an eye out. A few attempts I couldn't reproduce it so far

I'd like to know how to put a key frame from nowhere ? i mean without moving a part of the drawing or without copy paste from earlier key frame

a missing feature that will be returning soon

also how to use the thing to make smooth animation with png export ?

The png export has a few ways to specify the smoothness of the animation

exporttopngsmooth.PNG

keyframes only will only export 1 image per mainline key.

you can choose the total number of images exported(more is smoother), interval between frames(how much time inbetween each exported frame, smaller is smoother), and fps(frames per second, more is smoother), which should automatically update the values. Adjust these values to the desired amount of target frames or framerate

and if i want to make a part of the body move (by the tweening motion) but i want the head to stay exactly at the same place as it was from the last keyframe, how can i proceed with copy paste ? it didn't work and if i check the angle and position of the body parts it always has the same settings everywhere on the timeline

I'm not totally clear on what you mean with the question. If I understand you correctly, you're trying to move one part, but the other parts are being tweened? if so you can just copy the whole frame (diamond key) to the new position, and then move the body part

PS : i need to uninstall previous spriter version before installing the newest ones ??

no, just install over the previous version. and for the daily builds, just copy the exe over the one in the installation folder

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...