Jump to content

Spriter R11 Bug Thread


Recommended Posts

  • 4 weeks later...

When I select multiple sprites at once and drag them around the canvas (with the mouse) they move at different angles and speeds instead of all together. When moving with the keyboard it works OK. But without mouse support Spriter 11 is pretty much unusable with this issue.

This problem doesn't occur in Spriter 10 and below. It's very frustrating we haven't seen Spriter 12 to resolve this as I'm stuck using Spriter 10 when I need the bug fixes that are in Spriter 11. Please provide an update on when we will see a new release that fixes this issue.

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

Hi! I'm using a steam version of Spriter Pro on Linux Arch and Windows 10 and when I'm trying to generate a gif image on Arch, Spriter crashes with such logs: image.png.b0345f25fb0452b2a7961a9512566aa8.png  

It seems like you are using imagemagick to create gifs, but spriter cannot find magic.xml file in my system. However, I have imagemagick installed and magic.xml file path: /etc/ImageMagick-7/magic.xml.

This is only linux problem. On Windows 10 everything is ok. Maybe you have an idea how can I solve this problem? Because I wanna generate gifs from Arch:-)

Link to comment
Share on other sites

  • 2 months later...

I am having a rather large issue in Linux (specifically Debian/Ubuntu).  I downloaded the trial version from the website to see how it all worked, and found that the key combination for creating bones does not work for me at all.  In Linux Alt+Click will begin to drag the window.  I have tried this in JWM and LXQt (two different Desktops)  and the result is the same.

Can you please make this configurable, or at least change it to something that doesn't interfere with standard Window Manager keyboard shortcuts (in X11).

I think using the 'Super' key (a.k.a. the windows key or the 'Meta' key)

I have been enjoying trying this program out, but this missing basic functionality is a show stopper for me.

So yeah please add in

//I haven't seen your code... but probably you are using
// so please add this, or make it configurable

Or let me browse the code :D

Link to comment
Share on other sites

  • 1 month later...

When using texture Packer as the source: Saving the project causes all my pivot points to reset to 0, 0 and I cant even get started. Let me show you.

I am using Windows 10 64 bit
I am using the version you download from the website, Release 11
Pro is activated

Here is how you reproduce this:

  •  I am using Texture packer to export Spriter specific file format. This means exporting an image and a piece of JSON
  •  I then target the folder with spriter and begin a new project
  • spriter correctly detects the JSON and makes a 'folder' of the images. So far, so good.
  • I then set any pivot point on any image (where you see in the gif starting.)
  • I can reopen and confirm points are saved, as you see.
  • Now, either I will save, or the 'autosave' will save.
  • Now the work I did is reset to 0, 0

Also when the save or autosave occurs, the program will periodically crash as well.
This happens specifically when using texture packer, and not when simply targeting images in a directly.

here is a gif of it happening. Pardon any gif artifacts, that was to reduce the size so you could see it happening.



Link to comment
Share on other sites

  • lucid unpinned this topic
  • 1 year later...
On 4/22/2017 at 7:34 PM, EternaL said:

Hey! Just started using the update. Something that likely wasn't intended: When selecting more than one image and dragging them, they don't drag at the same rate. They each scroll across the screen at different paces. You'll likely see what I mean if you open r11 and try it. It's kind of funny-looking.

Assuming this is in fact a bug this time (I can't see how it isn't!) as opposed to some new feature, that requires any immediate edit to r11, I'd like to once again poke in my little feature suggestion, since it seems simple enough, to me, at least: save and load the workspace, like other softwares do. (Not a bug report, I know.)


Edit: I don't know if this is a bug, but Spriter loves forgetting that I changed every image's pivot point to the desired (and the only useful kind) red pivot dot. So I'm constantly, manually, changing them all to red again, even after I already did. Character maps are dependent on selected pivot points. Please get rid of clear pivot points and ratios. Make the red pivot point occur by default, even when images are attached to bones, as they often are. The fact that this isn't the case by default is just inefficient. At least fix it to remember red pivot points when manually changed to them.

Edit2: In case this helps, I noticed a series of events that will cause the all-important first key in animations to ditch the desired red pivot points: First, I check and confirm that the pivot point of a boned image is in fact red. I then make a character map active that happens to make Hidden the image with the red pivot point. I make a change in that key, such as moving another image. I remove all character maps, unhiding that red pivot image again, and see that the red pivot point has reset back to the useless clear one. Conclusion: Making a change in a keyframe while a character map is active will reset the desired red pivot points back to the bad and obsolete clear ratio-based ones. (that should be eliminated from Spriter)

I still get this bug where the images move at different speeds - Is there any workaround for this? 

Link to comment
Share on other sites

On 8/31/2017 at 2:59 PM, MoonStar said:


1. I selected 2 images

2. I scaled their x down to 0 on the object properties panel

3. Wrongly clicked another sprite and moved it

4. pressed ctrl+z to undo this action

5. crash


reproduceable: always




Things should be much more stable if you never set any dimension attribute to zero. If you set it to something like 0.01 instead you should get the results you want. Let me know if that helps avoid the crashing issue as well. Thanks.


Link to comment
Share on other sites

On 4/25/2017 at 7:51 PM, RogerPaladin said:

When I set the scale of x and the scale y of the object to 0, it moves to the point (680000, 680000) and then it is impossible to work with this object.

Yes, please everyone never set a scale ratio to zero.. something like 0.01 will give you the same results and avoid all the bugs around using zero.

Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...