Jump to content
gmalone

Is current Spriter Pro for Ubuntu usable in 16.04?

Recommended Posts

As the subject asks...  Ubuntu 16.04 and Spriter Pro .. a good match?  I ask because the download link says "for 14.04"

Also, can I use my purchase code for Windows version on my Ubuntu installation?  (I've switched OS's)

Thanks.

Greg

Share this post


Link to post
Share on other sites

For compatibility on any particular system/OS combination, your best bet is to try it and find out. We only officially support Ubuntu 14, because that's what Steam officially supports.

You can use your one Spriter Pro serial number to unlock your pro features on any computer you own, regardless of OS.

 

cheers.
Mike at BrashMonkey
 

Share this post


Link to post
Share on other sites

I managed to get Spriter Pro working on Ubuntu 18.04 Bionic Beaver

TLDR; compiled gstreamer-0.10.36 and gst-plugins-base-0.10.36 and copied required libraries to the Spriter directory

  1.  Download the source files from https://launchpad.net/ubuntu/+source/gstreamer0.10/0.10.36-1.5ubuntu1 and https://packages.ubuntu.com/source/xenial/gst-plugins-base0.10
  2. compile gstreamer0.10 - run
    $> ./configure
    this should complete successfully then run
    $> make
    this gave me an error at line 67 in gst/parse/grammar.tab.c, this is actually only an issue at line 1824 where the function requires 2 arguments and only one is given, just add a second argument of 0 to the yylex function
     yychar = yylex (&yylval);
     yychar = yylex (&yylval, 0);

    then run make again,  and this should complete with warnings but without error as it did for me

     

  3. compile gst-plugins-base-0.10.36 run

    $> export PKG_CONFIG_PATH=<path to gstreamer-0.10.36>/pkgconfig
    $> ./configure

     

  4.  

     copy the needed libraries from gstream-0.10.36 and gst-plugins-base-0.10.36 to the Spirter directory (for me it was ~/.steam/steam/steamapps/common/Spriter )
    as you try to run spriter it will tell you each of the libraries that are missing for me it was

    ./gst-plugins-base-0.10.36/gst-libs/gst/app/.libs/libgstapp-0.10.so.0
    ./gstreamer-0.10.36/libs/gst/base/.libs/libgstbase-0.10.so.0
    ./gst-plugins-base-0.10.36/gst-libs/gst/interfaces/.libs/libgstinterfaces-0.10.so.0
    ./gst-plugins-base-0.10.36/gst-libs/gst/pbutils/.libs/libgstpbutils-0.10.so.0
    ./gstreamer-0.10.36/gst/.libs/libgstreamer-0.10.so.0
    ./gst-plugins-base-0.10.36/gst-libs/gst/video/.libs/libgstvideo-0.10.so.0

    $> cp ./gst-plugins-base-0.10.36/gst-libs/gst/app/.libs/libgstapp-0.10.so.0 ./gstreamer-0.10.36/libs/gst/base/.libs/libgstbase-0.10.so.0 ./gst-plugins-base-0.10.36/gst-libs/gst/interfaces/.libs/libgstinterfaces-0.10.so.0 ./gst-plugins-base-0.10.36/gst-libs/gst/pbutils/.libs/libgstpbutils-0.10.so.0 ./gstreamer-0.10.36/gst/.libs/libgstreamer-0.10.so.0 ./gst-plugins-base-0.10.36/gst-libs/gst/video/.libs/libgstvideo-0.10.so.0 ~/.steam/steam/steamapps/common/Spriter

     

after that make sure steam is running and Spriter should work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×