Jump to content

Keyframe Dragging Bug?


LeonFook
 Share

Recommended Posts

Hi, kinda new to this software. it's kinda easy to use, but...

spriter%20error.gif

Yeah. After i select a bunch of keyframe in the timeline, dragging it will sometime cause some keyframe to simply disappear(i circle the keyframe that's suppose to be there with my mouse). It's kinda frustrating sometime tho. I'm using Steam version, downloaded today, so i guess it's the latest. Also is there a place i can report for bug? or is it here?

Link to comment
Share on other sites

Not sure if the causes are related, but I also encountered missing keyframes (actually ALL of my keyframes disappeared except the last one in the timeline) when I used the "Copy Z-order to Other Frames" and then "Undo" (because I didn't realize it copies to ALL other frames, not letting you select which ones....I know that's useful in some cases, but in my case, I'm trying to do body rotations where the Z-order changes a lot, and so obviously it doesn't work in my case, destroying earlier Z-reordering work I had done.)

Thankfully I had saved just beforehand (autosave is nice, but even at 1 minute intervals, it's still a pain to recover, figure out what you had done and not done yet, and redo it.)

Link to comment
Share on other sites

1 hour ago, GimmickyApps said:

Not sure if the causes are related, but I also encountered missing keyframes (actually ALL of my keyframes disappeared except the last one in the timeline) when I used the "Copy Z-order to Other Frames" and then "Undo" (because I didn't realize it copies to ALL other frames, not letting you select which ones....I know that's useful in some cases, but in my case, I'm trying to do body rotations where the Z-order changes a lot, and so obviously it doesn't work in my case, destroying earlier Z-reordering work I had done.)

Thankfully I had saved just beforehand (autosave is nice, but even at 1 minute intervals, it's still a pain to recover, figure out what you had done and not done yet, and redo it.)

Hi, I'm not sure I understand.. you seem to be mentioning a few separate things.

1) Copy z order to all frames effects all frames, and not just selected ones. This is true. I'm not sure if we'd be able to add this to Spriter... Spriter 2 (in very early development) will make things like this easier though.

2) missing key-frames. The only cause I know of for what seems like disappearing key frames is a glitch when you multi-select key frames than click and drag one of them and they all telleport to the same position in the timeline as the one you started dragging.
I'll double-check to see if that's fixed or not for the next build.

Did I understand this all properly?

Cheers.

-Mike at BrashMonkey

 

Link to comment
Share on other sites

The things in brackets were not the main thing I was talking about, they were just context.  Thank you for your comment about 1) though, good to know future versions will handle it better.  I think that part I communicated OK / you understood.  :)

Re: 2), I'm not sure you understood that I'm telling you a second cause, which is picking "copy z order to all frames" followed by "undo".  I haven't tested it repeatedly, but it happened just then that when I did this, all my keyframes (except the last one, which I had selected just before copying z order) disappeared.  Further "undo" did not bring them back, nor did "waiting just in case the computer is still thinking."

The reason I posted on this thread is that I thought perhaps the cause of my problem and the OP's problem may be related, since the symptom is related.

Cheers,

GA

 

 

4 minutes ago, BrashAdmin said:
4 minutes ago, BrashAdmin said:

Hi, I'm not sure I understand.. you seem to be mentioning a few separate things.

1) Copy z order to all frames effects all frames, and not just selected ones. This is true. I'm not sure if we'd be able to add this to Spriter... Spriter 2 (in very early development) will make things like this easier though.

2) missing key-frames. The only cause I know of for what seems like disappearing key frames is a glitch when you multi-select key frames than click and drag one of them and they all telleport to the same position in the timeline as the one you started dragging.
I'll double-check to see if that's fixed or not for the next build.

Did I understand this all properly?

Cheers.

-Mike at BrashMonkey

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...