Jump to content

Help, Problem with character maps and construct 2


MelVin
 Share

Recommended Posts

Hi all,

I've been having some issues switching between Entities in Construct2. Not only that , but the new Entities added to the Spriter file are not importing when I re import my spriter file. The first entity is there but none of the parts for the 2nd entity import. The Spriter file seems to be functioning normally in Spriter, it seems to be just the import process not recognizing the folder with the 2nd Entity files.

BTW I have also baked "Active to Entity" and save to both scml and scon. Sorry for the noob questions but I'm totally lost. Any help would be Greatly appreciated.

Cheers

Link to comment
Share on other sites

Hi Mike,

Thanks for the response:)

I did a bunch of testing last night and it doesn't seem to be related to my project specifically, I tried importing the spriter project into the "template" platformer capx and the same problem occurred. I see the images associated with the first entity but nothing that is in the 2nd entity is imported into Construct 2.

With my spriter project I have tried merging 2 spriter projects together multiple times with both options available, cloning the first entity, using Character maps and I even swapped out the images manually ( only the first frame of the 2nd entity to save time) just to see if they would import. Nothing has worked.

The only info I can find is this video...

So I have done exactly as it shows. Both folders(entity1 and entity2) share the same naming convention (entity1/DakooHead.png and entity2/DakooHead.png etc etc) So I am wondering if this is a problem for Spriter considering there has been updates and the video was only a preview.

In short, what I need is a list, short hand even, of the proper steps one needs to take to have all images export/import properly. And confirmation that someone else has gotten this to work.

Thanks for all your help.

Cheers,

Clayton

Link to comment
Share on other sites

Hi again Clayton,

I'm afraid I'm a little confused now...becuase Character Maps has nothing directly to do with "entities"..although I think you can create a new identity by "baking" current char-maps to an entity...

I can say the current version of the C2 Spriter plug-in does NOT support Character maps yet... but it does support multiple entities as far as I've seen and used it... but maybe there's a bug.

I'd really need to see your actual Spriter fiels and Capx to be able to figure out what the issue is. Obviously there is an NDA implied...I'd never share or show what you're working on to anyone.. I'd be happy to sign an actual NDA first if that would make you feel better about it.. I just want to help resolve your issue.

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Sorry for the confusion, I see I could have been more clear. But really I was way off, it's not the images. They ARE importing, I just didn't realize they are stored in different frames of the image. The problem is the entity is not swapping in Construct2. I made a simple test file and the problem still occurs. I'll email you the files right away.

I'm not worried, no need for NDA's, I apologize if I gave that impression, I just hate wasting peoples time. But at this point I don't think I can get this one. Hopefully the files are so small that my error/bug will be easier to spot. Thanks for all of the help.

Link to comment
Share on other sites

No problem at all MelVin,

I did a bunch of experimenting and it seems the problem is that you have the images in the main folder... this should not cause any issues...so technically its a bug.. I'll report it to Edgar.

For now, the solution seems to be to make sure you never use images i nthe main folder, and only in sub-folders.

I'll report back here when the issue is fixed in C2, but it will likely not be very soon as Edgar is very busy with Spriter itself.

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Thanks for figuring this out so quickly. :D I've copied the contents into 2 mirrored folders. I now have the spriter file and the 2 folders with the images in a separate directory. Now I'm wondering, how do I redirect spriter to point to the new folders/ file structure? Is this even possible or do I have to start the anims again? Hope this makes sense.

Cheers

Link to comment
Share on other sites

After reading your last post I did exactly the same as above but with the test files I sent you, I was able to swap Entities. So I moved on to the full assets

I separated the files into separate spriter files, making sure that the spriter files are in the root directory outside of the images folder. like so...

Spriter Character/Dakoo_Anims.scml

Spriter Character/Dakoo_Anims/(images)

Spriter Character2/Fuggin_Anims.scml

Spriter Character2/Fuggin_Anims/(images)

I then proceeded to merge the spriter files.

everything seems fine in Spriter but again I still can't swap the Entity in Construct2. I tried repeatedly, trying every merge option available and still nothing. Are you sure it's the structure causing the problem?

Link to comment
Share on other sites

  • 2 weeks later...

Finally got it working. Seems that spriter saved/kept erroneous entries in the folder were the spriter file was located even though there was no files in this location. So I manually edited the Spriter file removed these entries. Each one had 2 calls for the same image, I jsut removed the ones calling the root folder. After that I was having trouble with either the swaps or the naming conventions. Not sure which was the culprit, but I did get it to work giving each folder it's own naming convention or prefix

Spriter Character/Dakoo_Anims.scml

Spriter Character/Dakoo_Anims/(Dakoo_images)

Spriter Character2/Fuggin_Anims.scml

Spriter Character2/Fuggin_Anims/(Fuggin_images)

I did have to rebuild the 2nd characters anims, no matter what I tried it just kept messing up but now all seems fine. Regardless, thanks for pointing me in the right direction :D , I hope this helps anyone else having the same problem.

Cheers

Link to comment
Share on other sites

Hi MelVin,

I'm glad you got the issue resolved, and sorry I couldn't have been more help. On the plus side, this issue will eventually be fixed in the C2 plug-in (and obviously any bugs found in Spriter) and then things will go much more smoothly for everyone and issues like this won't slow us down anymore.

cheers,

Mike at BrashMonkey

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...