Jump to content
Sign in to follow this  
Mike at BrashMonkey

Please post bugs here.

Recommended Posts

Hi,

And first thanks for you work ;)

Next the Bug :)

Concerned version: Spriter Alpha version A3

Issue: App crashing suddenly

Platform: Mac Book Pro with Mac OS X Lion (10.7.4)

How to reproduce:

1 - Launch Spriter.app

2 - Open "Window" > "Objects In Frame"

3 - Wait 3 seconds

Share this post


Link to post
Share on other sites

New bug :)

Concerned version: Spriter Alpha version A3

Issue: App crashing suddenly

Platform: Mac Book Pro with Mac OS X Lion (10.7.4)

How to reproduce:

1 - Launch Spriter.app

2 - Create an animation

File > New Project > Choose a root folder > Drag & Drop an image into File Palette > Use this image to make the animation (several key frames)

3 - Save Project (File > Save Project As...)

4 - Play the animation (to see if it seems good) and next Pause.

5 - Try to export (File > Export To PNG ... > enter a new file name)

6 - Wait some seconds

If I don't play the animation (to see if it seems good) before to export, it works well, I succeed to get my exported images.

Share this post


Link to post
Share on other sites

Hi, first off, thanks for your work on Spriter, it's a lovely idea.

I've just started playing with it, and I've found a couple of bugs. Only one is a crash bug but I keep running into it

---

Deleting current keyframe, then scrubbing, causes crash

To repro:

- open monster sample

- double click any keyframe to jump to it

- Choose Edit->Delete

- Scrub the timeline

OSX 10.7.4 Lion, Spriter A3 (although the About box says A2, so perhaps its a packaging issue, as I've read elsewhere in this thread that this issue should be fixed)

Share this post


Link to post
Share on other sites

Spriter A3 with Hotfix

On my MAC, crashes every time I open the sample file:

Process: Spriter [14215]

Path: /Applications/Spriter.app/Contents/MacOS/Spriter

Identifier: com.yourcompany.Spriter

Version: ???

Code Type: X86-64 (Native)

Parent Process: launchd [145]

User ID: 501

Date/Time: 2012-09-09 22:29:35.243 +0100

OS Version: Mac OS X 10.8.1 (12B19)

Report Version: 10

Interval Since Last Report: 233858 sec

Crashes Since Last Report: 3

Per-App Crashes Since Last Report: 3

Anonymous UUID: 23ACED32-6BF4-4909-A914-F5611AB19B44

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000115233000

VM Regions Near 0x115233000:

MALLOC_LARGE 0000000115000000-0000000115233000 [ 2252K] rw-/rwx SM=PRV

-->

CG image 0000000115400000-0000000115601000 [ 2052K] rw-/rwx SM=PRV

Share this post


Link to post
Share on other sites

I'm not sure if this is a bug or a feature, but whenever I select any object in the frame to examine it, a new keyframe is created. I expected a new keyframe to be created when a value is modified (or when I click the "create keyframe" button).

Also animation cloning is disabled in the latest alpha (a3.1 HOTFIX), which is a pretty big problem for me since lots of animations kind of segway to and from others.

Bug reporting aside, I am ECSTATIC to use Spriter to take my game animations to the next level :D

Share this post


Link to post
Share on other sites

Bugs I have found in 5 minutes with the Windows version (09/18/12 daily build):

-- grabbing to drag a node is hit and miss. I can click in the middle of the node, and get about 25% success rate moving the node. Isnt this a basic functionality?

-- changing the run time from default 1000ms results in a hash mark each ms... so for 480ms length, we get 480 hash marks. Does not happen on Mac version.

-- still no numbers on the time line. Tired of trying to count the hundreds of hash marks. Completely unusable without numbers.

-- moving an object (rearrange z order) in the "Objects in Frame" window resets scale to 1.000 on both axis. Basic functionality not working.

-- cant grab the anchor point and move it. hover over the anchor point, the circle expands, but clicking does nothing. Basic functionality not working.

-- cant grab the rotation arm and rotate the node. Another basic functionality that just doesnt work.

-- nothing works... I scaled a node via the properties box, and then moved it (again via property box because I cant click and drag). it then reset the scale to 1.0, but left the node scaled down. Putting it back to 0.5 scaled the node down even further.

So... how are bones coming again? Might I humbly suggest fixing the basic functionality before adding new features.

Share this post


Link to post
Share on other sites

I'm not so sure one needs to complain about the daily builds here... might want to keep it in the backer sections.

...For what it's worth, I didn't have any of the issues you did except the z-order/scale thing. -WinXP 32bit

...and for bones you hold Alt while clicking the left mouse button in the main view window. They were added last week. ;)

I want a finished (Pro) version yesterday as well, but I have to keep telling myself to leave it alone for now. They have been saying to expect the 1.0 version in December, so until January rolls around let's not release the hounds. They have plenty of time to button things up.

As long as the public builds keep showing improvement (and fixes) it's all good.

Share this post


Link to post
Share on other sites

i repeat myself here..

do you have a ballpark numbers for when we could expect some basic usability features like copy& paste of keyframes, undo/redo, duplication of animations, grouping of sprites etc. :)

edit: btw is there a reason you write the file format suffix SCML uppercase? this makes alot of problems with case sensitive engines and the more or less general rule to write such stuff lowercase.. :D

its nice to see new features being developed.. but somehow imho it would be best to build features on solid ground.. and from a usability pov, spriter is still faar away from being used properly..

its getting to the point where its frustrating

cheers

Share this post


Link to post
Share on other sites
Bugs I have found in 5 minutes with the Windows version (09/18/12 daily build):

-- grabbing to drag a node is hit and miss. I can click in the middle of the node, and get about 25% success rate moving the node. Isnt this a basic functionality?

-- changing the run time from default 1000ms results in a hash mark each ms... so for 480ms length, we get 480 hash marks. Does not happen on Mac version.

-- still no numbers on the time line. Tired of trying to count the hundreds of hash marks. Completely unusable without numbers.

-- moving an object (rearrange z order) in the "Objects in Frame" window resets scale to 1.000 on both axis. Basic functionality not working.

-- cant grab the anchor point and move it. hover over the anchor point, the circle expands, but clicking does nothing. Basic functionality not working.

-- cant grab the rotation arm and rotate the node. Another basic functionality that just doesnt work.

-- nothing works... I scaled a node via the properties box, and then moved it (again via property box because I cant click and drag). it then reset the scale to 1.0, but left the node scaled down. Putting it back to 0.5 scaled the node down even further.

So... how are bones coming again? Might I humbly suggest fixing the basic functionality before adding new features.

bugs experienced in the daily builds should be posted in the private forums, and I'd like to reiterate not to use them for serious work, and in general please read the original daily build thread titled "Daily builds for Windows begin now 8/23/12" which explains to expect daily builds to in general be much less useable and more experimental than the actual releases.

I'm having a different bug with rearranging in zorder, and I'll fix that for the next build. For me it's resetting to 0,0 xy, but the scale is remaining.[EDIT]. These are new bugs introduced by the bone codebase, and one of the reasons for daily builds is so people can report things I don't find myself, and I can fix them before release, so thank you for the bug report. I can't reproduce either of your bugs with clicking and dragging of anchor points or rotation arms. Try them in yesterday's daily build to see if you're having the same problem. If you'd prefer to avoid seeing in-between version bugs like this, daily builds are definitely not the way to go.

there are definitely some problems with the properties boxes that I will fix as time goes by. I try to fix all reported bugs and crashes before each new build, as well as add additional functionalityg. Everyone has their pet features - yours is numbers in the timeline, others have said that Spriter is useless without bones. Still others said it was useless without export to PNG, which was added in the previous build.

There is only one programmer at Brashmonkey at the moment, and I cannot add everything everyone wants into each build. You might say that numbers in the timeline is such a small feature it should take only 5 minutes to add[EDIT], but there are hundreds of things that will take only 5 minutes to add. Our general policy has been to continue to add major features in broad strokes, fixing the bugs that new features leave in their wake along the way. After the program has all functionality, we will go in and add polish, make everything pretty and tidy, and spend the remaining time fixing bugs. 1.0 is estimated for December release. The current build is still in alpha, and as such should be expected to have bugs and not be a complete product. Some of the new things added will introduce bugs with older features, which will be fixed as they are discovered.

i repeat myself here..

do you have a ballpark numbers for when we could expect some basic usability features like copy& paste of keyframes, undo/redo, duplication of animations, grouping of sprites etc. :)

edit: btw is there a reason you write the file format suffix SCML uppercase? this makes alot of problems with case sensitive engines and the more or less general rule to write such stuff lowercase.. :D

its nice to see new features being developed.. but somehow imho it would be best to build features on solid ground.. and from a usability pov, spriter is still faar away from being used properly..

its getting to the point where its frustrating

cheers

No particular reason the suffix is in uppercase. It's changed starting in today's daily builds in the forums.

copy paste of keyframes, undo/redo, duplication of animations will all be in the next release on our around october 1st.

grouping of sprites will come later. bones provide some of the same uses as well as their own advantages, and will arrive in the next build as well.

I understand everyone's frustration with bugs and incompleteness of the software. Bear with us a little longer, as bones is the last large feature that requires major additions to the codebase. After this is added, things should start to flesh out and become more stable more quickly. Also, next update will have links to a bug/feature tracker. We realize forum threads are not the ideal way to do this.

Share this post


Link to post
Share on other sites

Hi, I've got some new observations. I see that object are deselected when I jump between frames. It would help a lot if they stay selected. Similar thing is with property grids in left pane. Their fold/unfold state is frame-bound, but should be global, imo.

Is there any public build coming soon? :)

Share this post


Link to post
Share on other sites

Found subtle bug in scml. Whenever angle value goes down, there should be spin="-1" attribute in key node, right? However it's not added on very small angle changes (smaller than 0.001?). This bug caused weird 360 degree spins in our engine, because it interprets spin very strictly :)

Share this post


Link to post
Share on other sites

It seems that in the latest Spriter alpha (a3), file paths below the project directory are specified as absolute (e.g. "/home/me/image.png" or "c:\Users\me\image.png"). In the interest of portable SCML files, I think all paths in SCML should be relative to the project directory. Perhaps in the cases where this is not possible (because separate Windows drives have distinct prefixes), the resources could be copied to the project directory or else the user is notified of the problem via popup and asked to copy the files to the same drive.

Share this post


Link to post
Share on other sites

a4:

- timeline is zoomed to max if you change the animation length (marking the complete number and then typing); probably because the zoom is already changed after input of the first digit

- spin arrows change animation length in 1000ms steps, seems a bit much

- time length of keyframes is not saved correctly; is saved as if animationlength is still 1000ms; animation length is saved correctly;

or is this correct behaviour and the implementation has to scale the animation length to the correct length?

Share this post


Link to post
Share on other sites

- time length of keyframes is not saved correctly; is saved as if animationlength is still 1000ms; animation length is saved correctly;

or is this correct behaviour and the implementation has to scale the animation length to the correct length?

The time attribute is the position on the timeline, not a duration. To work out the duration you'll need to find the difference of the time values on the current key frame and the next key frame.

For tweened objects the has an that points to an appropriate in a You must then use the current time and the times in the and the that follows it in the file to work out the tween.

Cheers,

Tim

Share this post


Link to post
Share on other sites

This I do understand.

The problem was that I assumed the editor would scale the keyframes if I changed the max length of the movie. So keyframe at 900 would become keyframe at 450 if max length changed from 1000 to 500. Just a misunderstanding on my part, sorry.

Good work on this new version.

And without platform-specific problems in Windows 8 so far.

Share this post


Link to post
Share on other sites

When manually setting values (e.g. bone location) the tab order is unintuitive/annoying. (e.g. press tab when in x field does not move cursor to y field but to y scale field.)

And those settings don't update when moving a bone around.

--edit--

And undoing seems somewhat buggy, too - with things not ending up were they were before.

Share this post


Link to post
Share on other sites

I'll fix the tab order mr wonko, but I'm not having the problem with the coordinates not updating while moving the bone. As far as undo. I'll be on the lookout, but if you happen to notice the exact situation it happens in. I know the quick answer might seem like 'very often' or 'all the time', but if you can pinpoint the exact situation(i.e.: undoing after moving a bone which has a parent bone), I can track and fix it much more quickly.

Share this post


Link to post
Share on other sites
As far as undo. I'll be on the lookout, but if you happen to notice the exact situation it happens in. I know the quick answer might seem like 'very often' or 'all the time', but if you can pinpoint the exact situation(i.e.: undoing after moving a bone which has a parent bone), I can track and fix it much more quickly.

Obviously, yeah. I'll take a look once I've got the time, I'm in the middle of some coding at the moment though. Oh, talking about coding (and sorry for derailing the thread) - where can I get info on the current file format? Is the Candidate for final file format (expanded) still up-to-date? I'll probably write an implementation in Löve2D for FuckThisJam! so it'd be useful to have a reference.

Share this post


Link to post
Share on other sites

Some of these are bugs and some features... or bugs :]

* Pressing the "Add Keyframe" on the timeline will crash Spriter in an empty project.

* When you change "Animation Length" to less than 1000, the timeline gets rescaled and then you have to rescale up.

* The selection in the viewport is deselected when you move the slider in the timeline.

* Whenever you change a value, the change is commited directly. Say, you enter size to be 0,2, if you enter 0 the sprite will crash the program (since it can't have a value of zero I would assume). Wait to make the changes until the user deselects the window or alternatively press enter.

* When using scale-constraint (SHIFT) you should be able to press SHIFT after you've started scaling and it will snap back to original "uniform" scale. Instead of just using the new scale ratio to constrain it.

* After undo, all my gizmos are super small.

* You can't use the right click IK anchor or inheritence unless your window is maximized.

Share this post


Link to post
Share on other sites

I've encountered a weird bug that keep happening to me.

Even though all the parts are in the folder "parts", when I reload the file it will move some parts to another folder, ending up like this:




















and it should be:

   















I've never moved the files, or renamed them... or anything.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...