Jump to content
CJM94

Help with importing my Spriter files into Unity

Recommended Posts

So I've been working with Spriter to create a handful of characters for my game. However, now that the animations are complete, I've been trying to implement them into my Unity Project. I'm currently using Unity 2018.3.12f1 Personal. There are more up to date versions currently but due to other assets in the project being difficult after a Unity update, I've decided to stick with this version unless absolutely necessary.

Now, on to the problem I'm facing currently. I have looked into SpriterDotNet.Unity for importing my animations into Unity. However, I'm running into these errors when I imported the package into Unity:

Assets\Spriter2UnityDX\Editor\PrefabBuilder.cs(42,65): warning CS0618: 'ReplacePrefabOptions' is obsolete: 'This has turned into the more explicit APIs, SavePrefabAsset, SaveAsPrefabAsset, SaveAsPrefabAssetAndConnect'
Assets\Spriter2UnityDX\Editor\PrefabBuilder.cs(42,15): warning CS0618: 'PrefabUtility.CreatePrefab(string, GameObject, ReplacePrefabOptions)' is obsolete: 'Use SaveAsPrefabAsset or SaveAsPrefabAssetAndConnect instead.'
Assets\Spriter2UnityDX\Editor\PrefabBuilder.cs(159,51): warning CS0618: 'ReplacePrefabOptions' is obsolete: 'This has turned into the more explicit APIs, SavePrefabAsset, SaveAsPrefabAsset, SaveAsPrefabAssetAndConnect'
Assets\Spriter2UnityDX\Editor\PrefabBuilder.cs(159,4): warning CS0618: 'PrefabUtility.ReplacePrefab(GameObject, Object, ReplacePrefabOptions)' is obsolete: 'Use SaveAsPrefabAsset or SaveAsPrefabAssetAndConnect with a path instead.'
Assets\Spriter2UnityDX\Editor\PrefabBuilder.cs(172,6): warning CS0618: 'TextureImporterSettings.ApplyTextureType(TextureImporterType, bool)' is obsolete: 'ApplyTextureType(TextureImporterType, bool) is deprecated, use ApplyTextureType(TextureImporterType)'
 

and then when I try and import my animations folder I get:

Assertion failed on expression: 's_AssetProgressBar.dialog'
UnityEditorInternal.InternalEditorUtility:ProjectWindowDrag(HierarchyProperty, Boolean)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
 

Overall, I'm a little lost on how to import them into my project and with deadlines looming I'm hoping I can get some help here.

Share this post


Link to post
Share on other sites

Hi CJM94,

In the intro you say you are using SpriterDotNet for Unity, but the error message is for Spriter2UnityDX, which are two completely different runtimes that handle using Spriter animations in Unity in very different ways.

Did you install one but are trying to use it like it's the other?

Here's the GitHub page for SpriterDotNet for Unity : https://github.com/loodakrawa/SpriterDotNet which currently gives some warnings but seems to work, but the author says on his Github page he plans to update it soon.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...